OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Install harvester-2.3.0's problem?

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

Install harvester-2.3.0's problem?

Postby sotan » Mon Mar 02, 2009 8:22 pm

Dear,sir.
I install harvester-2.3.0,it will problem:

Notice: Use of undefined constant MB_OVERLOAD_STRING - assumed 'MB_OVERLOAD_STRING' in C:\harvester-2.3.0\lib\pkp\classes\core\String.inc.php on line 58

Warning: Cannot modify header information - headers already sent by (output started at C:\harvester-2.3.0\lib\pkp\classes\core\String.inc.php:58) in C:\harvester-2.3.0\lib\pkp\classes\core\PKPRequest.inc.php on line 31

my install Environment is:
IIS5.0,PHP5.16,mysql5.0,windows xp

I don't know how to resolve,i get your help.
thanks and regards!
zhoukanpei
sotan
 
Posts: 3
Joined: Mon Mar 02, 2009 2:12 am

Re: Install harvester-2.3.0's problem?

Postby mj » Wed Mar 04, 2009 6:56 am

Hi zhoukanpei,

Thanks for letting us know about this issue. The message you're seeing is only a warning from PHP because the mbstring library hasn't been compiled on your system. This has been filed as a bug at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=4108 and there is a patch available there if you're comfortable applying it. Otherwise, you can suppress warnings and notices from PHP by using the error_reporting() function, documented fairly well elsewhere in this forum.

Hope this helps,
MJ
mj
Site Admin
 
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada

another problem with 2.3

Postby luko28 » Fri Apr 10, 2009 7:12 am

Hi,
I was searching this forum for this kind of problem, but I didn't find anything...
I (hope so) installed harvester 2.3 but I've got a strange error:
"Fatal error: Call to a member function getSiteIntro() on a non-object in /home2/lublinla/public_html/harvester/pages/index/IndexHandler.inc.php on line 28"
Any ideas what is causing it, and how can I resolve it?
luko28
 
Posts: 2
Joined: Fri Apr 10, 2009 7:06 am

Re: Install harvester-2.3.0's problem?

Postby asmecher » Fri Apr 10, 2009 8:56 am

Hi luko28,

It sounds to me like your installation wasn't complete. The error message you quote suggests that there's a missing entry in the "site" table, which should've been created on install.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: Install harvester-2.3.0's problem?

Postby luko28 » Fri Apr 10, 2009 1:20 pm

I see that something is wrong... I started everything from beginning, upload to server, change permissions, launch the installer (via http) and: first error can't connect to the database, access denied // I've created user, then second error: DB Error acces denied // I've created a database and add this user to it, and error that it can't find table "sites"... Shouldn't it do this by itself... Server I'm working on is:
Linux
Apache 2.2.11
php 5.2.9
mysql 5.0.75
i don't have access to the shell
What I'm doing wrong...?
luko28
 
Posts: 2
Joined: Fri Apr 10, 2009 7:06 am

Re: Install harvester-2.3.0's problem?

Postby asmecher » Tue Apr 14, 2009 9:38 am

Hi luko28,

Just to verify -- once the database has been created, and access has been granted to a user, you should go to the installer form, fill in the required info, and click the "Install" button. If you're not seeing the installer form, you may need to set the "Installed" option to "Off" in config.inc.php. If that still doesn't help, try turning on the show_stacktrace option in config.inc.php and post the resulting error dump here.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: Install harvester-2.3.0's problem?

Postby cyb3rb0ss » Fri Aug 07, 2009 2:47 am

First of all I have to mention that I am a real newbie.

I am using wampserver and I have just downloaded Harvester version 2.3.0 and unzipped it is the "www" folder.
When I am trying to install it the followin errors appear :

Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\pages\install\PKPInstallHandler.inc.php on line 38
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\pages\install\PKPInstallHandler.inc.php on line 60
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\pages\install\PKPInstallHandler.inc.php on line 83
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\pages\install\PKPInstallHandler.inc.php on line 94
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\lib\adodb\adodb-xmlschema.inc.php on line 367
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\lib\adodb\adodb-xmlschema.inc.php on line 379
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\lib\adodb\adodb.inc.php on line 896
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\lib\adodb\adodb.inc.php on line 1922
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\lib\adodb\adodb.inc.php on line 1994
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\CacheManager.inc.php on line 27
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\CacheManager.inc.php on line 41
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\CacheManager.inc.php on line 60
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\CacheManager.inc.php on line 72
Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 55
Warning: get_class() expects parameter 1 to be object, string given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, string given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, string given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\xml\XMLParser.inc.php on line 46
Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\xml\XMLParser.inc.php on line 289
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, string given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, null given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: get_class() expects parameter 1 to be object, string given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\cache\GenericCache.inc.php on line 63
Warning: Parameter 2 to BlockPlugin::callback() expected to be a reference, value given in C:\wamp\www\harvester-2.3.0\lib\pkp\classes\plugins\HookRegistry.inc.php on line 79

Sorry for the long post, but I really cannot understand what happens.

Btw, the "installed" option is Off in the config file of harvester...
cyb3rb0ss
 
Posts: 4
Joined: Fri Aug 07, 2009 2:39 am

Re: Install harvester-2.3.0's problem?

Postby asmecher » Fri Aug 07, 2009 12:24 pm

Hi cyb3rb0ss,

These messages should be harmless -- most result from changes in PHP since the last release of the Harvester. I'd suggest redirecting PHP error messages to a log file by modifying your php.ini -- this is a good policy for a production server anyway.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: Install harvester-2.3.0's problem?

Postby mcolmene » Wed Sep 02, 2009 6:04 am

Hello, I´m newbie too:
When I unzip the download file I get the advice: The file is corrupt.
After that I can´t install it. It seem that Smarty.class are missing.
Thanks
mcolmene
 
Posts: 2
Joined: Wed Sep 02, 2009 5:33 am


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 1 guest