OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Incorrect archive_id given while updating records

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Incorrect archive_id given while updating records

Postby singhkarki » Mon Jan 27, 2014 11:07 pm

hello Sir,
I have harvested a repository with archive_id =20 ,the records are fine. Later i harvested another repository with archive_id =21, the logs for the harvest are as follows:
UPDATE records
SET
archive_id = '20',
schema_plugin_id = '1',
identifier = 'KOHA-OAI-TEST:9036',
datestamp = null,
what happened was ,the archive previously harvested got incorrect data after i harvested second archive.
How can i resolve this error so that during harvesting of second archive i get the following logs:
UPDATE records
SET
archive_id = '21',


Please suggest ,
thanks and regards,

Vijay
Last edited by singhkarki on Tue Jan 28, 2014 10:09 am, edited 1 time in total.
singhkarki
 
Posts: 51
Joined: Fri Nov 29, 2013 3:28 pm

Re: Incorrect archive_id given while updating records

Postby asmecher » Tue Jan 28, 2014 5:21 am

Hi Vijay,

I suspect this is still related to archives serving the same record identifiers. If you solve that problem and re-harvest all of your archives, this should no longer happen.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 2 guests

cron