OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Registering Your OAI-PMH 2.0 Repository

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

Registering Your OAI-PMH 2.0 Repository

Postby Albert » Wed Oct 16, 2013 3:57 pm

Trying to validate our site for registration with OAI “Registering Your OAI-PMH 2.0 Repository” (http://www.openarchives.org/data/regist ... vider.html), as per OJS Register Site for Indexing (Metadata Harvesting) set up, I entered http://pub.iengj.com/?journal=index&page=oai in the validation box. Nevertheless, I get this response:

Checking Identify response
Request: GET http://pub.iengj.com/?journal=index&pag ... b=Identify
[FAIL] Server at base URL 'http://pub.iengj.com/?journal=index&page=oai' failed to respond to Identify. The HTTP GET request with URL http://pub.iengj.com/?journal=index&pag ... b=Identify received response code '404'.

What can I do to fix this?
The journal is on OJS 2.4.1. While setting the journal up, on Step 1 “General Information” we do not see the DOI box to enter the journal DOI Prefix.
Regards,
Albert
 
Posts: 36
Joined: Wed Jan 02, 2013 12:43 pm

Re: Registering Your OAI-PMH 2.0 Repository

Postby asmecher » Wed Oct 16, 2013 4:20 pm

Hi Albert,

See http://pkp.sfu.ca/support/forum/viewtopic.php?f=4&t=7740#p40672.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9212
Joined: Wed Aug 10, 2005 12:56 pm

Re: Registering Your OAI-PMH 2.0 Repository

Postby Albert » Sun Oct 20, 2013 4:26 pm

Hi Alec,
I did as you told but when I turned off disable_path_info I could open the home page of the site, but I could not login nor open any menu on the site. I always got error 404 "Site was not found." Therefore, it seems that this is not part of a solution of this problem.
Thank you so much for your quickly answer.
Regards,
Albert
Albert
 
Posts: 36
Joined: Wed Jan 02, 2013 12:43 pm

Re: Registering Your OAI-PMH 2.0 Repository

Postby asmecher » Sun Oct 20, 2013 6:18 pm

Hi Albert,

This setting was probably enabled in the first place because your server does not support PATH_INFO URLs. You'll have to fix that first, most likely using web server configuration directives, before OJS will work with path_info_disabled turned off.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9212
Joined: Wed Aug 10, 2005 12:56 pm


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 3 guests