OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Fatal error: Class 'HookRegistry' not found

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Fatal error: Class 'HookRegistry' not found

Postby eroldan » Mon Aug 01, 2011 2:26 am

Hi, I have 2 sites runnin OCS, I've instaled the 2nd one because I began to have a problem when I tried to login and I got an error like:

Fatal error: Class 'HookRegistry' not found ...

I installed other OCS in the same server, and everything works fine, but yesterday I got the same problem:

Fatal error: Class 'HookRegistry' not found in /var/www/ciies/lib/pkp/classes/db/DAO.inc.php on line 194

I tried to acces in the old site and now it works fine, I can login as if there wasn't any problem it is confusing, and I dont know how to fix it, in the second site I have configured a conference which is active now :( please help me.

I read in the Drupal's forum and they sugest to clean the Registry using a script:

http://drupal.org/project/registry_rebuild

I don't know if it is something similar an if there is something like.

Thanks in advance
eroldan
 
Posts: 2
Joined: Mon Aug 01, 2011 1:45 am

Re: Fatal error: Class 'HookRegistry' not found

Postby eroldan » Tue Aug 02, 2011 7:20 pm

SOLVED!! It was an APC problem , I unninstall APC and it solved the problem.

Now I have to change the cache accelerator :roll:
eroldan
 
Posts: 2
Joined: Mon Aug 01, 2011 1:45 am


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest