OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problem with common/message.tpl

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Problem with common/message.tpl

Postby tshore » Tue Apr 26, 2011 12:13 pm

Author registration has closed. The attachment shows the page that is displayed when a non-author clicks on the Abstract Submission link. As you can see, there is a problem with some of the items from the locale file. I started to try to look into this, but I have no idea.

Perhaps it's a bug?

OCS 2.3.3.1

Screen shot 2011-04-26 at 2.53.19 PM.png
Screen shot 2011-04-26 at 2.53.19 PM.png (130.5 KiB) Viewed 1400 times
tshore
 
Posts: 266
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Problem with common/message.tpl

Postby jmacgreg » Fri Apr 29, 2011 2:09 pm

Hi Trudy,

I can't seem to replicate this on my git checkout, but you may be running into http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5547. Try the attached patch and see if the problem is resolved.

Cheers,
James
jmacgreg
 
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am

Re: Problem with common/message.tpl

Postby tshore » Wed Nov 09, 2011 11:50 am

Just setup a brand new installation of OCS 2.3.4 and I still have this exact same problem. When a non-author clicks on on the Submission link, they get this same messed up page. It is not bug #5547 as that patch has been incorporated into OCS 2.3.4.

I have figured this out, partly by searching the forum and finding this post:

http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=7080

So, even if a user doesn't have the Author role assigned to their profile, when they click on the Submission link, they are automatically assigned this role. I was ending up on the messed up page because the Author registration opened date was set to a future date on the timeline management page and so the user could not be assigned the author role.
tshore
 
Posts: 266
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Problem with common/message.tpl

Postby michael » Tue Nov 15, 2011 12:49 pm

Hi Trudy,

Thanks for tracking this down.

I've filed it as a bug here.

Cheers,
Michael
michael
 
Posts: 409
Joined: Thu Mar 29, 2007 2:09 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests