OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OCS 'Error 500' upon uploading users via XML

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

OCS 'Error 500' upon uploading users via XML

Postby BTC » Sat Oct 16, 2010 1:52 pm

Hello all,

First off, let me say that from what I've seen in the OJS/OCS programs, I'm thoroughly impressed.

I'm running into a problem right now that I am sure has been tackled on here many times, yet could not find it via search.

When I go to upload my XML file of my membership database in OCS, I get the following:

Code: Select all
Error 500 - Internal server error

An internal server error has occured!
Please try again later.


The directory of this error is:

Code: Select all
http://[i]mysite.com[/i]/obts/ocs/index.php/obtc_2011/OBTC/manager/importexport/plugin/UserImportExportPlugin/confirm


Upon response, please do take into consideration that I'm a bit of a novice that is just diving more heavily into SQL and PHP.

Thanks in advance for your assistance! And keep up the great work on this program!

-BTC
BTC
 
Posts: 3
Joined: Sat Oct 16, 2010 12:50 pm

Re: OCS 'Error 500' upon uploading users via XML

Postby jmacgreg » Tue Oct 19, 2010 11:22 am

Hi BTC,

Have you taken a look to see if any more detailed errors are being reported in your error logs? See this FAQ entry and the next for some error-finding suggestions.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: OCS 'Error 500' upon uploading users via XML

Postby BTC » Wed Oct 20, 2010 1:38 pm

(Simply warning again, a bit of a noob alert here)

Inputting that 'error code' to the beginning of the index.php brought up some new errors and won't allow me to log in now. This is what it spits out:

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /homepages/9/d298573713/htdocs/obts/ocs/index.php:1) in /homepages/9/d298573713/htdocs/obts/ocs/classes/session/SessionManager.inc.php on line 56

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /homepages/9/d298573713/htdocs/obts/ocs/index.php:1) in /homepages/9/d298573713/htdocs/obts/ocs/classes/session/SessionManager.inc.php on line 56

Warning: session_regenerate_id() [function.session-regenerate-id]: Cannot regenerate session id - headers already sent in /homepages/9/d298573713/htdocs/obts/ocs/classes/session/SessionManager.inc.php on line 209

Warning: Cannot modify header information - headers already sent by (output started at /homepages/9/d298573713/htdocs/obts/ocs/index.php:1) in /homepages/9/d298573713/htdocs/obts/ocs/classes/core/Request.inc.php on line 41



Thoughts? Ideas? Obviously this isn't the issue I originally brought up, which I'll still need to solve somehow once I can recreate it in the error log.
BTC
 
Posts: 3
Joined: Sat Oct 16, 2010 12:50 pm

Re: OCS 'Error 500' upon uploading users via XML

Postby BTC » Wed Oct 20, 2010 1:54 pm

Now I'm not sure if that had anything to do with showing the error log. I removed it and uploaded the index.php again and the errors are still showing at the top of my browser.

Odd stuff. Wish I knew how to get this up and running for our non-profit. It looks so promising.
BTC
 
Posts: 3
Joined: Sat Oct 16, 2010 12:50 pm

Re: OCS 'Error 500' upon uploading users via XML

Postby asmecher » Wed Oct 20, 2010 3:05 pm

Hi BTC,

Check and see if there is a blank line inserted by accident at the very beginning of your index.php script -- something as small as that would make the difference.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests