OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OCS: upgrade 2.1.2 to 2.3.1

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

OCS: upgrade 2.1.2 to 2.3.1

Postby mikestu » Mon May 10, 2010 11:41 am

hi ...

my environment is:
- windows server 2003 ent
- apache 2.2.8
- php 5.2.6
- postgresql 8.3.1.1

i try upgrade ocs 2.1.2 to version 2.3.1, i read file .../docs/UPGRADE and i follow the instructions to upgrade full package but the upgrade failed


in file $APACHE_HOME/logs/error.log i see this error:

[Mon May 10 19:19:22 2010] [error] [client xxx.xxx.xxx.xxx] PHP Warning: require_once(core/PKPRequest.inc.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in $APACHE_HOME\\Apache2.2\\htdocs\\_ocs\\includes\\functions.inc.php on line 21
[Mon May 10 19:19:22 2010] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'core/PKPRequest.inc.php' (include_path='.;$APACHE_HOME\\Apache2.2\\htdocs\\_ocs/includes;$APACHE_HOME\\Apache2.2\\htdocs\\_ocs/classes;$APACHE_HOME\\Apache2.2\\htdocs\\_ocs/pages;$APACHE_HOME\\Apache2.2\\htdocs\\_ocs/lib;$APACHE_HOME\\Apache2.2\\htdocs\\_ocs/lib/smarty;.;C:\\php5\\pear') in $APACHE_HOME\\Apache2.2\\htdocs\\_ocs\\includes\\functions.inc.php on line 21

I tried several times to upgrade but always failed, and asked, the upgrade work?

best regards
mikestu
 
Posts: 15
Joined: Thu May 01, 2008 10:49 am

Re: OCS: upgrade 2.1.2 to 2.3.1

Postby mikestu » Wed May 12, 2010 4:28 am

anybody help me?????
mikestu
 
Posts: 15
Joined: Thu May 01, 2008 10:49 am

Re: OCS: upgrade 2.1.2 to 2.3.1

Postby asmecher » Fri May 14, 2010 1:16 pm

Hi mikestu,

Can you verify that lib/pkp/classes/core/PKPRequest.inc.php exists and is accessible by the web server (i.e. file permissions are correct)?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9214
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests