OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OCS 2.1.1.2 => 2.3.0.0 DB upgrade fail

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

OCS 2.1.1.2 => 2.3.0.0 DB upgrade fail

Postby JohnGrobler » Thu Apr 15, 2010 3:31 am

Good day,

I am trying to perform a Full Package upgrade from OCS 2.1.1.2 to OCS 2.3.0.0 and receive the following error when trying to perform the DB upgrade from either the web interface or CLI:

ERROR: Upgrade failed: DB: Duplicate entry 'REVIEW_ACK-0-1' for key 2

Hosting environment:
Apache 2.2.3
PHP 5.2.0-8
MySQL 5.0.51a

Can this problem be related to another issue experienced on this OCS site, logged here: viewtopic.php?f=3&t=5980

Thank you,
John Grobler
JohnGrobler
 
Posts: 51
Joined: Mon Dec 07, 2009 1:41 pm

Re: OCS 2.1.1.2 => 2.3.0.0 DB upgrade fail

Postby mcrider » Tue Apr 20, 2010 11:49 am

Hi John,

This is likely caused by an upgrade on an already failed upgrade (thus on a fractured database). Please try restoring from backup to a stable state, then trying to upgrade again.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests