OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



DB Error upgrading from OCS 2.1.2-1 to 2.3

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

DB Error upgrading from OCS 2.1.2-1 to 2.3

Postby raphael » Wed Jan 27, 2010 9:57 am

hi,
I tried to ugrade OCS from 2.1.2-1 to 2.3 with
Code: Select all
patch -p1 < ocs-2.1.2-1_to_2.3.patch

Patching went OK.

Then upgrading DB with
Code: Select all
php tools/upgrade.php upgrade

gave this error :
Code: Select all
[load: upgrade.xml]
[version: 2.3.0.0]
[schema: lib/pkp/xml/schema/common.xml]
[schema: lib/pkp/xml/schema/groups.xml]
[schema: lib/pkp/xml/schema/announcements.xml]
[schema: lib/pkp/xml/schema/controlledVocab.xml]
[schema: lib/pkp/xml/schema/scheduledTasks.xml]
[schema: lib/pkp/xml/schema/temporaryFiles.xml]
[schema: dbscripts/xml/ocs_schema.xml]
[data: dbscripts/xml/upgrade/2.3.0_update.xml]
ERROR: Upgrade failed: DB: Champ 'assoc_type' inconnu dans field list


in english : field 'assoc_type' unknown in field list

I found 'assoc_type' in my OCS DB in tables ending with *_event_log but i don't know what to do to correct this DB error...

Does anybody have an idea of what to do ?

thank you,

raphael
raphael
 
Posts: 4
Joined: Tue Jan 12, 2010 9:37 am

Re: DB Error upgrading from OCS 2.1.2-1 to 2.3

Postby mcrider » Wed Feb 03, 2010 11:26 am

Hi Raphael,

I just attempted this upgrade and it worked fine. I'm concerned maybe the patch didn't work properly, in which case I would suggest trying the 'Full package' upgrade method detailed in docs/UPGRADE. Also, was your OCS 2.1.2 upgraded from a previous version?

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: DB Error upgrading from OCS 2.1.2-1 to 2.3

Postby raphael » Thu Feb 04, 2010 1:59 am

Thank you for your reply Matt,

I didn't upgraded OCS but i applied the Patch against OCS 2.1.2 mentionned it this bug report :
http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5033

Patch details :
http://pkp.sfu.ca/bugzilla/attachment.c ... ction=edit

And I am almost sure this is why it didn't work as expected. I'll try the 'Full package' upgrade, if it doesn't work I think i will come back to a vanilla OCS 2.1.2 and then upgrade again with the upgrade patch. I might also restore only the patches files from a vanilla OCS.

I'll try that and report successfull attempts in case someone followed my upgrade path.

cheers,
raphael
raphael
 
Posts: 4
Joined: Tue Jan 12, 2010 9:37 am


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests