OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Standard Reports in Reports & Stats

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Standard Reports in Reports & Stats

Postby RickMath » Mon Nov 09, 2009 10:59 pm

There seems to be a bug in the Papers Report. When I run the report, the author, the paper id, title and abstract are not correct for any rows.

I have exported the tables from our database and created a query in MS Access to create a similar file. This gives me the correct results.

I would be glad to attach the sample excel files for your review.

This is a minor item for me as I have access to the system tables. For others who do not have direct access and wish to get the report this poses a potential problem.

Just wanted to let you know.

Rick
RickMath
 
Posts: 263
Joined: Fri Feb 27, 2009 12:30 am

Re: Standard Reports in Reports & Stats

Postby mcrider » Tue Nov 10, 2009 2:19 pm

Hi Rick,

What version of OCS are you using? There were some errors found in 2.1.1 but should be fixed in the latest release as per bug 4418.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Standard Reports in Reports & Stats

Postby RickMath » Tue Nov 10, 2009 2:58 pm

Matt

Thanks. We are using 2.1.2

Seems as if the same bug exists as the one you referred to. I can send you the csv file and what i generated in a query from the tables exported from the MySQL database.

Just let me know.

Rick
RickMath
 
Posts: 263
Joined: Fri Feb 27, 2009 12:30 am

Re: Standard Reports in Reports & Stats

Postby mcrider » Wed Nov 11, 2009 11:55 am

Hi Rick,

Yes, if you could send those via PM, that would be great.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Standard Reports in Reports & Stats

Postby Kirstensuhr » Sun Dec 20, 2009 7:13 am

Hi guys

We have had the same depressing problem, abstract id and title dose not match the authors. Makes you look really bad when you take out an owerview for track directors and they go "This is not right, he cannot have written an abstract in with that title". Klaus, our php programmer, have made a work around so I can take out reports, but the code is not looking good. Can you tell me what happende??

I seems like the sorting of the data that I take out in the csv /excel is orderd after title of the abstract and not after abstract number.

We are running 2.1.2.1 and upgraded on (November 12, 2009 - 01:44 PM) but what happened?

Kirsten
Kirstensuhr
 
Posts: 5
Joined: Tue Apr 07, 2009 3:07 am

Re: Standard Reports in Reports & Stats

Postby mcrider » Sat Dec 26, 2009 9:34 am

Hi Kirsten,

I've put a bunch of papers in my OCS test install, but I can't reproduce this problem (and apologies to Rick for not following up on your old email to me regarding this, it must've fallen into an inbox black hole). However, the code that prints out the papers report is rather complex so a bug could very well be hidden in there. Kirsten, would you be able to give me your output of the papers report (or even a snippet of it) and also what you expect to be displayed? Is it possible that your CSV-viewer (e.g., MS Excel) is automatically ordering the columns? For me, the papers are sorted by title, but the paper ID column (the first one) isn't in numeric order. Conceivably, your software may automatically sort the paper ID column, causing the confusion. Let me know if you have anything else that could point me towards reproducing this bug.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Standard Reports in Reports & Stats

Postby RickMath » Sat Dec 26, 2009 3:16 pm

Hi Matt

I ran another report on the papers. When I open the report the Submission ID and the Title are correct but the sumittin ahor information is incorrect. The file is not sorted by the Submission ID. Interestingly the Track Names for the papers are also correct.

Just thought I would add this.

Thanks

Rick
RickMath
 
Posts: 263
Joined: Fri Feb 27, 2009 12:30 am

Re: Standard Reports in Reports & Stats

Postby sfuchs » Thu Feb 04, 2010 9:19 am

Is there any update on this? My programmer's getting a little tired of me asking him to run reports from our OCS instances, and it would make my life easier if I could just do it myself. I've played around with the "Papers Report", but the information seems to be wrong. (I haven't done a thorough look, but the submission IDs are wrong, for one.)
Thanks!
Sara Fuchs
Digital Initiatives Librarian
Georgia Institute of Technology
sfuchs
 
Posts: 7
Joined: Tue Mar 17, 2009 11:28 am

Re: Standard Reports in Reports & Stats

Postby asmecher » Thu Feb 04, 2010 10:54 am

Hi Sara,

Try installing the patch against your version of OCS at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=4588. This should fix the papers report plugin.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9201
Joined: Wed Aug 10, 2005 12:56 pm

Re: Standard Reports in Reports & Stats

Postby sfuchs » Thu Feb 04, 2010 11:17 am

Thanks, Alec!
sfuchs
 
Posts: 7
Joined: Tue Mar 17, 2009 11:28 am

Re: Standard Reports in Reports & Stats

Postby RickMath » Thu Feb 04, 2010 11:57 am

Alec

Thanks from me also. I will try the patch later today and let you know.

Rick
RickMath
 
Posts: 263
Joined: Fri Feb 27, 2009 12:30 am

Re: Standard Reports in Reports & Stats

Postby petienne » Thu Feb 04, 2010 3:06 pm

Greetings PKP Community -

My "User" (think Tron) posted in to say that she was having trouble with the results from the OCS "Stats & Reports" page, specifically the "Papers Report". I'm offering the results of my testing.

I've take into account that spreadsheet applications may have strange initial behavior when reading csv files, but all results discussed here were confirmed by viewing the downloaded csv both through a current version of Microsoft Excel and a plain text reader (Textedit, OSX).

The csv uses a label titled "Submission ID", this seems to directly correspond to the "paper_id" field used in various tables in the database such as "papers", "paper_settings", and "paper_presenters".

The csv file's "Submission ID" and "Title" do match up with "paper_id" and "paper_settings.setting_value (where setting_name='title')" in the database. I found no cases of inaccuracies there.

The csv file's "Submission ID"/"Title" do not match with personal details of either:
1) The user that submitted the paper (users.first_name, users.last_name),
2) Any presenter associated with that paper (paper_presenters.first_name, paper_presenters.last_name).
I wasn't totally sure if this was supposed to be reporting on who submitted the paper, or who the "authors" were supposed to be. It didn't seem to matter because the results where not accurate for either case.

It seems as though there's a patch for this, though the original impetus for the patch was a very different issue, but I thought the details might help just in case. I'll post in if I have success with the patch.

- Patrick E.

PS - Thanks for checking into the reporting potentialities there Sara! Should hopefully make both our lives easier ;)
petienne
 
Posts: 15
Joined: Thu Feb 05, 2009 2:23 pm
Location: Atlanta, GA

Re: Standard Reports in Reports & Stats

Postby RickMath » Thu Feb 04, 2010 10:18 pm

Alec

It appears that there is still a bug in 4588. The patch indicates two LEFT JOIN lines with the first not followed by a WHERE

I do not know if this is causing the problem but I get an error.

Could you post the revised file for PaperReportDAO.inc.php

Michael did this with another file and it worked once I cleaned up the empty lines after the ?> at the end.

Thanks

Rick
RickMath
 
Posts: 263
Joined: Fri Feb 27, 2009 12:30 am

Re: Standard Reports in Reports & Stats

Postby asmecher » Fri Feb 05, 2010 11:11 am

Hi Rick,

What error message are you encountering?

You can get access to the various versions of all the files from http://pkp.sfu.ca/cvs/cvsweb.cgi -- go to ocs2 -> plugins -> reports -> papers -> PaperReportDAO.inc.php for all the details.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9201
Joined: Wed Aug 10, 2005 12:56 pm

Re: Standard Reports in Reports & Stats

Postby RickMath » Fri Feb 05, 2010 2:41 pm

Thanks Alec

This makes life easier for me as I can't execute any unix commands on our server.

I will let you know if this fixes the problem. I think copying and pasting from the patch files I missed something.

Rick
RickMath
 
Posts: 263
Joined: Fri Feb 27, 2009 12:30 am

Next

Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest