OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Fatal error: require_once()

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Fatal error: require_once()

Postby emiliano » Tue Aug 19, 2008 7:05 am

Hello!
I am trying the ocs 2.1. I was using without any errors for a few days and today when I want to use again I had have one warning and a fatal error.
If you can help me please I will be so plesant.
The warning and error are the followings:
____
Warning: require_once(plugins/HookRegistry.inc.php) [function.require-once]: failed to open stream: No such file or directory in /home/emiserf/public_html/rcem2009/includes/functions.inc.php on line 43

Fatal error: require_once() [function.require]: Failed opening required 'plugins/HookRegistry.inc.php' (include_path='.:/home/emiserf/public_html/rcem2009/includes:/home/emiserf/public_html/rcem2009/classes:/home/emiserf/public_html/rcem2009/pages:/home/emiserf/public_html/rcem2009/lib:/home/emiserf/public_html/rcem2009/lib/smarty:.:/usr/lib/php:/usr/local/lib/php') in /home/emiserf/public_html/rcem2009/includes/functions.inc.php on line 43
----
Thank you very much.
Emiliano

PD.: sorry by my english, I am from Argentina.
emiliano
 
Posts: 17
Joined: Tue Aug 19, 2008 6:57 am

Re: Fatal error: require_once()

Postby mcrider » Tue Aug 19, 2008 1:33 pm

Hi Emiliano,

Can you verify that the file at /home/emiserf/public_html/rcem2009/classes/plugins/HookRegistry.inc.php exists?

What page were you trying to access when you got this error? Have you made any modifications to the system since you last used it?

Regards,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Fatal error: require_once()

Postby emiliano » Wed Aug 20, 2008 7:07 am

Hi Matt!
Yes, the file exist, here is the result of "ls -l HookRegistry.inc.php":

-rw-rw---- 1 phot2006 phot2006 5085 Aug 18 05:22 HookRegistry.inc.php

I did some modifications writings about conferences, conference managers, etc, the changes were using the web interfaces.
The trouble apperar in the access to the system, I can't see the first page (index), so I can't use ocs.

Well, I had installed ocs to test it, in the next days I will renew the installation again because we need it in a production stage. But I want know about this problem, and the possible cause.

Thank you very much.

Emiliano.-
emiliano
 
Posts: 17
Joined: Tue Aug 19, 2008 6:57 am

Re: Fatal error: require_once()

Postby mcrider » Wed Aug 20, 2008 11:20 am

Hi again Emiliano,

Well, it seems that either your OCS installation is incomplete (in which case, I would suggesting reinstalling from a freshly downloaded version), or something has happened to your server. You can try also checking your server logs to see if anything strange is coming up. Are you using a LAMP (linux/apache/mysql/php) server?

Regards,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Fatal error: require_once()

Postby emiliano » Thu Aug 21, 2008 5:58 pm

Hi Matt,
The installation was finished, I think, correctly, because I use it and configure by the web interface. I created a conferences, change the colors, etc..
I am using a LAMP server: Apache 2.0.63, PHP 5.2.5, and MySQL 5.0.51a-community.
The version that I downloaded was ocs-2.1.0-1

If you want you can see the error message visiting: emi.serfe.com/rcem2009

Thank you very much again Matt.

Bye,

Emiliano
emiliano
 
Posts: 17
Joined: Tue Aug 19, 2008 6:57 am

Re: Fatal error: require_once()

Postby mcrider » Thu Aug 21, 2008 7:10 pm

Hi again Emiliano,

Hm.. This is likely a permissions problem. All of the directories in the main OJS directory (besides maybe the public and cache directories) should be chmod'ed 755. Could you check to make sure all of the permissions are set correctly?

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Fatal error: require_once()

Postby mcrider » Thu Aug 21, 2008 7:33 pm

Also, try chmodding the classes/plugins/HookRegistry.inc.php file 644, and see if the error resolves itself (or you get another one, in which case, you'll need to do that to all php files in OJS). Otherwise, what errors does your php/apache log give you when you try to access OJS?

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron