OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



SMTP Mail Problems -- Password Required?

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

SMTP Mail Problems -- Password Required?

Postby kurkoski » Tue May 20, 2008 12:39 am

Hello,

I am trying to get SMTP mail setup on OCS, and am having difficulties.

I am using the same SMTP server that my own mail client uses. My SMTP server appears to use no authentication, except via my IP address which is at the same university. I can telnet to the SMTP server on port 25, and the reply is 220 master.ice.uec.ac.jp ESMTP Sendmail 8.13.8+Sun/8.13.8; Tue, 20 May 2008 16:17:10 +0900 (JST). Then I send an email without being asked for a password.

But, after I attempt to send an email from inside OCS, I find the following in the server log:
[client 130.153.28.208] OJS SMTPMailer: Could not authenticate, referer: http....

Back at telnet, if, for example I try PLAIN or LOGIN authentication via telnet, I get an error.
C: AUTH PLAIN
S: 500 5.5.1 Command unrecognized: "AUTH PLAIN"
(This is per http://www.technoids.org/saslmech.html )

So my interpretation is that my SMTP server does not support PLAIN or AUTH, while OCS does not support "passwordless" mailing. There is still the chance that I've got my password wrong, but I don't know where to look for error logs.

I'm running my own web server, which does not have sendmail configured.

I look forward to your comments.

-Brian Kurkoski
kurkoski
 
Posts: 5
Joined: Thu May 15, 2008 1:14 am
Location: Tokyo, Japan

Re: SMTP Mail Problems -- Password Required?

Postby kurkoski » Tue May 20, 2008 6:27 pm

I have solved my own problem.

The solution, given at viewtopic.php?t=2609 , is to comment out the smtp_auth variable in config.ini.php.

I have two suggestions for the developers:
1. Instead of commenting out the smtp_auth for passwordless smtp, there should be an option like smtp_auth = NONE. If NONE is added to the brief instructions in the comment above the smtp_auth line, then it would be a clearer way to handle this SMTP server's configuration. (It appears that setting smtp_auth to anything other than the four listed options, has the same effect as commenting out the line. So setting smtp_auth = NONE gives the suggested behavior)

2. I was never able to find documentation on how to set up SMTP, instead I found out what I needed to do by reading the forums, which is less convenient. My suggestion is to add the documentation to http://pkp.sfu.ca/ocs_documentation .

Thank you for developing a very nice and easy-to-use piece of software.

-Brian Kurkoski
kurkoski
 
Posts: 5
Joined: Thu May 15, 2008 1:14 am
Location: Tokyo, Japan


Return to OCS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest