OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OCS 2.0.0.1 Installation problems

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

OCS 2.0.0.1 Installation problems

Postby alaindubois » Fri Feb 22, 2008 7:26 am

I have an ocs 2.0.0.0 working installation, I tried to install the 2.0.0.1 update to be able to work with french, and other langauge caracters and I got the following problems:

1 - Error in the the upgrade.xml file, it points to ojs schema. After changing to ocs I got the following problems.
2 - When running the OCS Upgrade I got the following error message: Errors occurred during installation: A database error has occurred: ERROR: duplicate key violates unique constraint "email_templates_default_pkey"
3 - I cannot find any locale files other then EN. Where can I donwload the other available language files?

Thanks
alaindubois
 
Posts: 5
Joined: Fri Feb 22, 2008 7:06 am
Location: Montréal

Re: OCS 2.0.0.1 Installation problems

Postby jmacgreg » Mon Feb 25, 2008 12:07 pm

Hi Alain,

Thanks for your comments. I believe that your first issue is a known bug, and I've asked one of our developers to take a look at the second issue. About the language files: you can download language packs from the pkp website:

For OJS: http://pkp.sfu.ca/ojs-languages
For OCS: http://pkp.sfu.ca/ocs-languages

At the moment, our language pages are unfortunately a little mixed up. I'll be working on cleaning them up, but in the meantime, we do have an up-to-date fr_FR translation for OCS 2.0.0-1, which I have attached. If you require fr_CA, I would suggest contacting the language maintainer listed on the OCS fr_CA language page.

Cheers,
James
Attachments
fr_FR.tar.gz
(63.29 KiB) Downloaded 40 times
jmacgreg
 
Posts: 4162
Joined: Tue Feb 14, 2006 10:50 am

Re: OCS 2.0.0.1 Installation problems

Postby asmecher » Mon Feb 25, 2008 6:15 pm

Hi alaindubois,

Regarding the second issue, where you were getting a duplicate insert error -- this is a known issue with the 2.0.0-0 to 2.0.0-1 upgrade. There's no need to run the upgrade script when migrating from one to the other, as the changes are minimal; I'd suggest manually updating the "versions" table to reflect the new version so that you won't run into problems with future upgrades. To do this, run the following in MySQL:
Code: Select all
UPDATE versions SET build = 1;
...which should modify a single row in the installation. Thereafter OCS will know that it's been updated to the 2.0.0-1 version. (I'm assuming you've already updated the code but were having trouble with the upgrade script, which is the second part of the process documented in docs/UPGRADE.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: OCS 2.0.0.1 Installation problems

Postby alaindubois » Tue Feb 26, 2008 8:25 am

Thanks Alec,

Updating the versions table and setting installed = On in config.inc.php worked. However I updated to 2.0.0.1 to be able tu use french character, but after the updatre it still does not work.

For exemple, when I enter "Érudit" as the site title in site settings I get "'Erudit" as the title. I tried setting the title directly in the database (postgres) with a sql statement and that worked. But with the "Site administration" web interface it does not work. I have attached my config.inc.php if it helps.

Alain
config.inc.php.zip
alaindubois
 
Posts: 5
Joined: Fri Feb 22, 2008 7:06 am
Location: Montréal

Re: OCS 2.0.0.1 Installation problems

Postby alaindubois » Tue Feb 26, 2008 9:50 am

Found the solution in another topic.

Correct code in Form.inc.php should be like this:

function setData($key, $value) {

if (is_string($value)) $value = Core::cleanVar($value);

$this->_data[$key] = $value;
}

Then it works.
alaindubois
 
Posts: 5
Joined: Fri Feb 22, 2008 7:06 am
Location: Montréal

Re: OCS 2.0.0.1 Installation problems

Postby alaindubois » Tue Feb 26, 2008 1:53 pm

Hi,

Now that I have french (non-western) caracters working I am trying to install french locales. I copied the xml files in the various folders and updages the locales.xml in the regestry folder with:
<locales>
<locale key="en_US" name="English"/>
<locale key="fr_CA" name="Français Canada"/>
<locale key="fr_FR" name="Français France"/>
</locales>

When I try to unse those languages in the site admin page, I do not see any other installed language then english. Any idea what to check?

Alain
alaindubois
 
Posts: 5
Joined: Fri Feb 22, 2008 7:06 am
Location: Montréal

Re: OCS 2.0.0.1 Installation problems

Postby jmacgreg » Tue Feb 26, 2008 10:18 pm

Hi Alain,

After editing registry/locales.xml and adding those lines, you should have a checkbox along with the locale names at the very bottom of the page, under a heading called "Install New Locales" -- is nothing showing up?

I'm also wondering about adding the line <locale key="fr_CA" name="Français Canada"/> -- did you retrieve the fr_CA locale package from the maintainers?

Thanks,
James
jmacgreg
 
Posts: 4162
Joined: Tue Feb 14, 2006 10:50 am

Re: OCS 2.0.0.1 Installation problems

Postby alaindubois » Wed Feb 27, 2008 7:33 am

Hi James,

Under "Install New Locales" it shows "No additional locales are available for installation."

As for the french locale I got the file from Kevin Stranack at SFU, stattin that those were the current french translation.

Alain
alaindubois
 
Posts: 5
Joined: Fri Feb 22, 2008 7:06 am
Location: Montréal

Re: OCS 2.0.0.1 Installation problems

Postby jmacgreg » Thu Feb 28, 2008 2:35 pm

Hi Alain,

I believe that the fr_CA tar file Kevin sent you was mislabled -- it is actually an older set of fr_FR files. Would you be able to delete the uploaded files and try again with just the fr_FR sets I sent you? You should also remove the fr_CA reference from the locales.xml registry.

Please let me know if you are still having problems.

Thanks,
James
jmacgreg
 
Posts: 4162
Joined: Tue Feb 14, 2006 10:50 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron