You are viewing the PKP Support Forum | PKP Home Wiki

Installation Problem - Please give me a hand (Urgent)!

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Installation Problem - Please give me a hand (Urgent)!

Postby vthung » Mon Dec 10, 2007 7:46 pm

Hi all,
I have just got started with OCS 2.0. When reaching the installation page (http://localhost/ocs/index.php?conferen ... op=install), the screen went blank without notifications, though I fully turned on error reporting in php.ini. Noticeably, I did everything necessary for the installation (PHP 5.2.2, Apache 2.2.6, MySQL 5.0.4). I spent sometime looking around the forum, but could not find a light at the end of tunnel.

Any suggestion is much appreciated.

Look forward to hearing from you soon,
Posts: 3
Joined: Mon Dec 10, 2007 7:32 pm

Re: Installation Problem - Please give me a hand (Urgent)!

Postby asmecher » Mon Dec 10, 2007 8:04 pm

Hi Vu,

From docs/FAQ:
7) The installation form loads successfully, but after clicking the button
to install, a blank page appears and the database was not created.

A: This may indicate that your server does not have the selected PHP database
module installed and enabled (this can be verified by looking at the output
of phpinfo() to see if the required database support exists -- see

The OJS installer lists database drivers for which the required PHP
extension does not appear to be loaded in brackets (e.g., "[MySQL]").

Most Linux distributions offer a separate package that can be installed for
each supported PHP database module -- e.g., php4-mysql or php-mysql (for
MySQL support), or php4-pgsql or php-pgsql (for PostgreSQL support).

Note also that even with the module installed it may be necessary to modify
your php.ini configuration to load the module, by adding "extension=mysql.so"
or "extension=pgsql.so", for example.
Alec Smecher
Public Knowledge Project Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Installation Problem - Please give me a hand (Urgent)!

Postby vthung » Tue Dec 11, 2007 7:40 am

Thanks Alec for your timely reply. I got it done successfully.

Have a nice day,
Posts: 3
Joined: Mon Dec 10, 2007 7:32 pm

Return to OCS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest