OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Nothing Appears Under "My Conferences" on User Home

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Nothing Appears Under "My Conferences" on User Home

Postby tshore » Mon Dec 10, 2007 3:17 pm

If you go here:

http://imrf.mcmaster.ca/IMRF/ocs/index.php/meetings/2008/

And try to login, of course, you won't be successful and will be taken here:

http://imrf.mcmaster.ca/IMRF/ocs/index.php/meetings/2008/login/signIn

Then, if you click here:

Not a user? Create an account with this site

And signup, it looks as if no role is being assigned, and, as a result, you are taken here:

http://imrf.mcmaster.ca/IMRF/ocs/index.php/index/index/user

This is not good for me, because (a) this is a hidden "layer" of the website and (b) for some reason, the one conference I have in the system is not listed under "My Conferences". In the case of the new signup, I think this is because no role has been assigned. However, it seems not to matter for this particular page. I have ended up here signed in as a reader, author and/or conference manager, but there is never anything listed under "My Conferences". That is, except when I'm signed in as an admin. So this is problem #1 for this post.

Now on to problem #2: I think that a default role of reader should be assigned to anyone that signs up via a link from a scheduled conference. I tried to make this happen by adding this:

Code: Select all
<input type="hidden" name="createAsReader" value="1"/>


at line 180 in:

templates/user/createAccount.tpl

but that didn't seem to make any difference.

Help please.
Last edited by tshore on Wed Dec 12, 2007 1:42 am, edited 1 time in total.
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Mon Dec 10, 2007 3:39 pm

A quick reply would be VERY much appreciated here. Timezone issue. I need to fix this first thing tomorrow morning - my time - which is in about 8 hours. I really can't wait for you to wakeup again 8 or 9 hours later.

Thank You,

Trudy
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby asmecher » Mon Dec 10, 2007 4:41 pm

Hi Trudy,

Can you check your database (the roles table) to ensure that the users you're talking about have roles?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8306
Joined: Wed Aug 10, 2005 12:56 pm

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Mon Dec 10, 2007 4:46 pm

I have checked the roles table and the new users have no roles. The other users I was testing out have the roles I mentioned.
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby asmecher » Mon Dec 10, 2007 5:11 pm

Hi Trudy,

And none of the users, regardless of whether there are roles in the database, have anything listed under My Conferences, except for the Admin user?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8306
Joined: Wed Aug 10, 2005 12:56 pm

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Mon Dec 10, 2007 10:35 pm

No, nothing appears there even when the users have roles.
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby asmecher » Tue Dec 11, 2007 10:42 am

Hi Trudie,

Some of the problems you're experiencing (e.g. this and http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=1819 appear to have a common root in role management or scheduled conference access or URL changes that I haven't been able to duplicate. Is it possible that you've modified a part of the system (e.g. to try to hide the second part of the URL, such as http://some-domain-name/index.php/one/two) in a way that's caused these problems to start appearing?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8306
Joined: Wed Aug 10, 2005 12:56 pm

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Wed Dec 12, 2007 1:34 am

I don't think the way I've hidden the extra layers of the website is causing these problems. I've mostly accomplished this by messing with the breadcrumbs, which I think is all in templates/common/header.tpl. I also commented out the navbar div.

My main problem is that the users are not being assigned roles when they signup using the sample procedure I outlined in my initial post on this thread. This is - I think - what's causing them to be sent to this higher level of the website in the first place:

http://imrf.mcmaster.ca/IMRF/ocs/index. ... index/user

Instead of being taken to:

http://imrf.mcmaster.ca/IMRF/ocs/index. ... /2008/user
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby asmecher » Wed Dec 12, 2007 3:48 pm

Hi Trudy,

I think I've found part of the problem -- the site-level User Home was not properly displaying roles for non-Admin users. See http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=3187 for a patch. Note that Reader roles are coded never to be displayed, but all other roles should be.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8306
Joined: Wed Aug 10, 2005 12:56 pm

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Thu Dec 13, 2007 4:15 am

Thank you. That patch fixes the title problem.

Now, back to the problem of users being created without roles...

Now on to problem #2: I think that a default role of reader should be assigned to anyone that signs up via a link from a scheduled conference. I tried to make this happen by adding this:

Code: Select all
<input type="hidden" name="createAsReader" value="1"/>


at line 180 in:

templates/user/createAccount.tpl

but that didn't seem to make any difference.


And, just to refresh your memory, I described the exact signup procedure that results in a role-less user in my first post in this thread.
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Tue Dec 18, 2007 2:47 pm

I replicated this problem on your demo site. Let me explain it again. I went to one of your demo conferences:

http://pkp.sfu.ca/ocs/demo/index.php/spc/pkpspc2008

And tried to login (without proper account info) and, of course, I wasn't successful and was taken here:

http://pkp.sfu.ca/ocs/demo/index.php/sp ... gin/signIn

Then, I clicked on:

Not a user? Create an account with this site

And I signed up without checking any role. (Note: on a site like mine where author registration is not yet open there isn't even the option to "Create account as" - ie. select a role). After signup, I was taken here:

http://pkp.sfu.ca/ocs/demo/index.php/index/index/user

And, as on my site, there were no conferences listed under "My Conferences".

I would like to avoid this scenario and, I as I stated earlier in the thread:

I think that a default role of reader should be assigned to anyone that signs up via a link from a scheduled conference.


Of course, assuming that the conference allows people to signup as readers.
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario

Re: Nothing Appears Under "My Conferences" on User Home

Postby asmecher » Tue Dec 18, 2007 5:08 pm

Hi Trudy,

This is probably caused by bug #2976 (http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=2976), which has already been corrected in CVS. (The testdrive installation uses a nearly-stock OCS 2.0 and has not been patched with this.) Try applying that patch and let me know if it corrects the problem.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8306
Joined: Wed Aug 10, 2005 12:56 pm

Re: Nothing Appears Under "My Conferences" on User Home

Postby tshore » Thu Dec 20, 2007 3:57 am

Thank you. I think that fixed it.
tshore
 
Posts: 264
Joined: Fri Nov 18, 2005 12:48 pm
Location: Hamilton, Ontario


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests