OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



oai harvester

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

oai harvester

Postby ppound » Thu Nov 08, 2007 1:34 pm

We tried to register for the harvester here http://pkp.sfu.ca/harvester2/demo/index ... ateArchive and get the error The specified OAI URL is not valid. Please check the URL and try again.

The urls we tried were, http://ocs.vre.upei.ca/index.php/aupac/index/oai and http://ocs.vre.upei.ca/index.php/index/index/oai. If I try to load these manually through a browser I get the below.

<OAI-PMH xsi:schemaLocation="http://www.openarchives.org/OAI/2.0/ http://www.openarchives.org/OAI/2.0/OAI-PMH.xsd">
<responseDate>2007-11-08T20:22:54Z</responseDate>
<request>http://ocs.vre.upei.ca/index.php/index/index/oai</request>
<error code="badVerb">Illegal OAI verb</error>
</OAI-PMH>

I checked the settings and OAI is turned on. Any ideas on what may cause this.

Thanks,
Paul
ppound
 
Posts: 13
Joined: Tue Jul 31, 2007 11:36 am

Re: oai harvester

Postby asmecher » Thu Nov 08, 2007 5:27 pm

Hi Paul,

Try applying the patch at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=3143 to your OCS installation. Let me know if it works.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9214
Joined: Wed Aug 10, 2005 12:56 pm

Re: oai harvester

Postby ppound » Fri Nov 09, 2007 10:20 am

Thanks Alec,
I applied the patch. Seems to have worked I was able to register the AUPAC conference. I did one just before for as a test called VREDiscussion that you can probably remove if you want as it is just a test conference.

Thanks again,
Paul
ppound
 
Posts: 13
Joined: Tue Jul 31, 2007 11:36 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests