OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



"URL" field in OCS user profile does not get saved

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

"URL" field in OCS user profile does not get saved

Postby nicolaspayette » Tue Oct 02, 2007 12:28 pm

Hi!

I'm trying to fill the "URL" field for my users in a OCS2 installation (in either the "People"/"Create New User" or "People"/Edit Profile" pages), but whatever information I put in there does not get saved. I don't get any error message; the field is just empty when I come back for editing.

Any cues?

Merci d'avance!

Nicolas
nicolaspayette
 
Posts: 5
Joined: Tue Oct 02, 2007 12:18 pm

Re: "URL" field in OCS user profile does not get saved

Postby asmecher » Tue Oct 02, 2007 2:38 pm

Hi Nicolas,

That's a known issue in OCS 2.0, and it's already been fixed in CVS. The original fix was for OJS, and a patch for that is available at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=2913; it should be a pretty clean back-port into your OCS 2.0 installation.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm

Re: "URL" field in OCS user profile does not get saved

Postby nicolaspayette » Fri Oct 05, 2007 1:14 pm

It works. Thanks, Alec!

One question, though. I manually edited the files. Is there a way I could have just "applied the patch"?

Nicolas
nicolaspayette
 
Posts: 5
Joined: Tue Oct 02, 2007 12:18 pm

Re: "URL" field in OCS user profile does not get saved

Postby asmecher » Fri Oct 05, 2007 2:45 pm

Hi Nicolas,

That particular bug is awaiting back-porting into OCS2; once that's done, a patch for OCS will exist. In the meantime, the patch you applied manually is "close but not quite close enough", meaning it'll need some manual intervention to apply.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests