OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OCS 2.0 Released

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

OCS 2.0 Released

Postby asmecher » Wed May 16, 2007 4:01 pm

The PKP Development Team is pleased to announce the release of OCS 2.0.

OCS 2.0 is a complete rewrite of the legacy OCS 1.x line. It uses the proven OJS 2.x codebase with numerous additions to the feature sets of both OJS 2.x and OCS 1.x. OCS 2.0 includes many new features that were not available in OCS 1.x:
  • Localization support for multiple user interface languages
  • Modern object-oriented codebase
  • Support for recurring conferences (i.e. held yearly)
  • Improved review system
  • Better support for multiple presentation formats
  • Updated Reading Tools
    ...and much more.
OCS 2.0 includes tools to migrate conference presentations and reviews from an OCS 1.1.5 or newer installation. Consult the docs/UPGRADE document in the distribution package for details.

To download OCS 2.0, see the download page.
asmecher
 
Posts: 8337
Joined: Wed Aug 10, 2005 12:56 pm

Postby ozp » Fri Jun 08, 2007 6:18 pm

whats new on Latest version: 2.0.0.1 ?

I have 2.0.0.0

Is there a way to upgrade?
ozp
 
Posts: 51
Joined: Sat Apr 28, 2007 9:01 pm

Postby asmecher » Sun Jun 10, 2007 8:27 pm

Hi ozp,

There are one or two very minor corrections to the code and locale files. To upgrade, apply the patch at http://pkp.sfu.ca/ocs/download/patch/ocs-2.0.0-0_to_2.0.0-1.patch.gz.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8337
Joined: Wed Aug 10, 2005 12:56 pm

Re: OCS 2.0 Released

Postby Peter_gup » Tue Oct 23, 2007 7:52 pm

does a patch exist for version 2.0b1 ?
Peter_gup
 
Posts: 2
Joined: Sun May 20, 2007 5:55 pm
Location: QLD, Australia

Re: OCS 2.0 Released

Postby asmecher » Wed Oct 24, 2007 9:48 am

Hi Peter_gup,

We don't distribute a patch for upgrading 2.0b1 to 2.0, but if you're familiar with CVS, you can generate one with the following command:
Code: Select all
cvs diff -u -N -D "2007-04-03" -r ocs-2_0_0-1 > update.diff
There are numerous changes between the beta and the final release of 2.0, and there is no scripted upgrade process in place. You'll at least need to use the tools/dbXMLtoSQL.php script to apply the following schemas:
  • dbscripts/xml/ocs_schema.xml
  • plugins/paymethod/paypal/schema.xml
I'd strongly recommend running a trial update from 2.0b1 to 2.0 on a copy of your current installation (including a copy of the database).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8337
Joined: Wed Aug 10, 2005 12:56 pm

Re: OCS 2.0 Released

Postby m.giordano » Wed Jan 09, 2008 5:39 am

Hi everybody,

I installed version 2.0.0-0 and upgraded code to version 2.0.0-1, but when I make "patch tools/upgrade.php patch" run it tells that database is still at version 2.0.0-0.
I also try to run "patch tools/upgrade.php upgrade" but it stops with this error: "Upgrade failed: DB: Duplicate entry 'PAYPAL_INVESTIGATE_PAYMENT' for key 2"
Is this normal?

Thanks

Marco

PS: the first time I run the DB upgrade script, it failed because it was looking for the file ojs_schema.xml instead of ocs_schema.xml. I modified accordingly the upgrade.xml file, but I got the error described above.

PPS: my System Information page still reports version 2.0.0-0...
m.giordano
 
Posts: 29
Joined: Wed Jan 09, 2008 4:02 am

Re: OCS 2.0 Released

Postby asmecher » Thu Jan 24, 2008 11:36 pm

Hi Marco,

The differences between OCS 2.0.0-0 and 2.0.0-1 are only a few lines of code; there is no need to run the upgrade script. If you've updated the code to 2.0.0-1 and the install is mis-identifying itself as 2.0.0-0, don't worry -- it won't cause any problems. This will be fixed with the next upgrade.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8337
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest