You are viewing the PKP Support Forum | PKP Home Wiki

two OCS installations on same server

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

two OCS installations on same server

Postby amdorino » Sun Sep 01, 2013 6:47 am

I currently don't have another working machine other than the production server, so I want to use it for dev purposes, for progamming in the db as well as in the code files.

The question is how to enable two installations of ocs with different databases (i.e, ocs, ocsdev).
Note that if config the second installation with the former ocs db, the installation is automatically up and ok, but I can modify only the second code and damage the shared database of the two installations

current situation:
Windows server with working (production) installation with databse ocs and virual folder 'OCSprod' ,
one more installation on the same server with virutal folder 'OCSdev'.
Trying to install the second installation (on the second physical folder of the second virtual directory) gives
error of session table doesn't exist. After importing the table ok, another error of another table doesn't exist ('site' table), again imported ok, then 'page cannot be displayed'.

Is there some definition that forbids the second database installation? and if so, can I solve this?
I tried with different usernames, but it seems the db is "singletoned".
Any suggestion?
Thanks a lot
Posts: 15
Joined: Mon Jul 01, 2013 11:20 am

Re: two OCS installations on same server

Postby asmecher » Tue Sep 03, 2013 9:12 am

Hi amdorino,

You can run several installations of OCS on the same server without trouble. I suspect you've copied your production installation, including the configuration file, for use as the dev installation -- if that's the case, make sure you also duplicate the database, and update the credentials to access it in config.inc.php. If (on the other hand) you want to run through the installation form on the dev installation, turn "installed" to Off in config.inc.php.

Alec Smecher
Public Knowledge Project Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests