OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



load language after partial manual translation

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

load language after partial manual translation

Postby amdorino » Sun Aug 04, 2013 10:15 pm

Hi,
I created a manual translation to a language not yet transated in OCS.
I loadded the xml files of locale and lib after being translated to their folders and changed the xml file of registry (without "complete" tag used)
What do I need to do to reload the OCS so this language is seen in the languages checkboxes? under languages there is only "english" in the picklist with no other option.
There is something more to loading the xml files, what should be done to get the OCS know that a new language is installed?
I followed the instructions in the wiki of translation.

Another question, how do I tell the OCS that language is right to left?
Thank You
amdorino
 
Posts: 15
Joined: Mon Jul 01, 2013 11:20 am

Re: load language after partial manual translation

Postby asmecher » Sun Aug 04, 2013 10:58 pm

Hi amdorino,

Make sure the language is added to registry/locales.xml, and make sure you've installed the language via the site administrator's Languages page.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron