OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS plugin: DNB URN + EPICUR

The Plugin Gallery is a venue for users of PKP software to share their plugins.

Moderators: jmacgreg, michael, John

Forum rules
If you post a plugin here, please include information on which versions of which applications it is compatible with. Attach a tarball of the plugin (e.g. tar cvzf myPlugin-0.1.tar.gz plugins/generic/myPlugin). Thanks for contributing!

OJS plugin: DNB URN + EPICUR

Postby swing » Wed Mar 27, 2013 8:49 am

The DNB URN plugin enables the assignment of the Uniform Resource Names according to the policies of the Deutsche Nationalbibliothek.
The EPICUR URN metadata plugin enables the registration of the URN-URL pairs via OAI at the Deutsche Nationalbibliothek.
See the documentation in German: http://pkp.sfu.ca/wiki/index.php/URNPlugIn_Doku

The plugins are part of the project "Functional extensions and value added services for OJS" located at the Freie Universität Berlin and founded by the Deutsche Forschungsgemeinschaft (DFG).
More about the project: http://www.cedis.fu-berlin.de/ojs-de

Please see the README files for installation instructions.

Author: Bozana Bokan
Software: OJS 2.4.2
Requirements: Same requirements as the OJS 2.4.2 core.
Attachments
epicur-1.0.tar.gz
Plugin version 1.0
(3.69 KiB) Downloaded 57 times
urnDNB-1.0.tar.gz
Plugin version 1.0
(9.85 KiB) Downloaded 74 times
swing
 
Posts: 138
Joined: Tue Oct 09, 2007 2:59 am

Re: OJS plugin: DNB URN + EPICUR

Postby swing » Tue Jun 11, 2013 5:34 am

Hello,

Here is the new version of the DNB URN plugin, that supports the overall OAI intereface (.../index/oai?verb=...) -- till now only the journal specific interface (.../journal/oai?verb=...) was supported.
Please see the README files for installation instructions.
Author: Bozana Bokan
Software: OJS 2.4.2
Requirements: Same requirements as the OJS 2.4.2 core.

Attached is also the patch for the version 1.0. To apply the patch please copy the file urnDNB-1.0_patch1.diff into your OJS directory and from there call:
patch -p1 < urnDNB-1.0_patch1.diff

Please note, that the EPICUR plugin hasn't changed.

Regards,
Bozana Bokan
Attachments
urnDNB-1.1.tar.gz
Plugin version 1.1
(10.1 KiB) Downloaded 60 times
urnDNB-1.0_patch1.diff
Patch 1 (for the version 1.0)
(1.57 KiB) Downloaded 52 times
swing
 
Posts: 138
Joined: Tue Oct 09, 2007 2:59 am

Re: OJS plugin: DNB URN + EPICUR

Postby swing » Wed Jun 12, 2013 3:44 pm

Hello,

Attached is the patch for the following bug: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8256. To apply the patch please copy the file urnDNB-1.1_patch1.diff into your OJS directory and from there call:
patch -p1 < urnDNB-1.1_patch1.diff

Regards,
Bozana Bokan
Attachments
urnDNB-1.1_patch1.diff
Patch 1 (for the version 1.1)
(1.3 KiB) Downloaded 45 times
swing
 
Posts: 138
Joined: Tue Oct 09, 2007 2:59 am

Re: OJS plugin: DNB URN + EPICUR

Postby swing » Thu Jun 13, 2013 3:13 am

Hello,

Here is the new version of the EPICUR plugin, that differently considers empty metadata elements (if there is no URN for an article) and adds identifier type="frontpage".
Please see the README files for installation instructions.
Author: Bozana Bokan
Software: OJS 2.4.2
Requirements: Same requirements as the OJS 2.4.2 core.

Regards,
Bozana Bokan
Attachments
epicur-1.1.tar.gz
Plugin version 1.1
(3.73 KiB) Downloaded 40 times
swing
 
Posts: 138
Joined: Tue Oct 09, 2007 2:59 am

Re: OJS plugin: DNB URN + EPICUR

Postby swing » Tue Jun 25, 2013 4:54 pm

Hello,

Here is a new version of the EPICUR plugin again, that in agreement with DNB brings back the first solution for the empty metadata elements (if there is no URN for an article).
Please see the README files for installation instructions.
Author: Bozana Bokan
Software: OJS 2.4.2
Requirements: Same requirements as the OJS 2.4.2 core.

Regards,
Bozana Bokan
Attachments
epicur-1.2.tar.gz
Plugin version 1.2
(3.75 KiB) Downloaded 51 times
swing
 
Posts: 138
Joined: Tue Oct 09, 2007 2:59 am

Re: OJS plugin: DNB URN + EPICUR

Postby swing » Mon Mar 24, 2014 11:28 am

Hello,

Here is a patch for the following issue: the 'Locale::translate' should be replaced with '__' -- the class 'Locale' doesn't exist any more, the class 'AppLocale' should be used instead.

To apply the patch please copy the file epicur-1.2_patch1.diff into your OJS directory and from there call:
patch -p1 < epicur-1.2_patch1.diff

Regards,
Bozana Bokan
Attachments
epicur-1.2_patch1.diff
patch 1
(796 Bytes) Downloaded 35 times
swing
 
Posts: 138
Joined: Tue Oct 09, 2007 2:59 am


Return to Plugin Gallery

Who is online

Users browsing this forum: No registered users and 1 guest