OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Allowed memory size exhausted

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Allowed memory size exhausted

Postby Edwin » Mon May 22, 2006 6:49 am

Hi,
When - in my role as editor - I tried to click on the submissions for more details, I got the following error:
'Allowed memory size of 8388608 bytes exhausted (tried to allocate 84665 bytes)'

I learned from this forum that this can be solved by changing the php.ini, but since my provider does not allow me to do this, is there a way to tweak around this problem? Or just find another provider :)

By the way, I recently upgraded to the latest version of OJS, that is 2.1.0.1

With best wishes,
Edwin
Edwin
 
Posts: 3
Joined: Mon May 22, 2006 6:27 am

Postby asmecher » Mon May 22, 2006 11:08 pm

Hi Edwin,

You'll need to find a way to increase the memory setting; you may be able to accomplish this by adding the following line near the top of OJS's index.php:
Code: Select all
ini_set("memory_limit", "16M")
Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9206
Joined: Wed Aug 10, 2005 12:56 pm

Postby Edwin » Mon May 22, 2006 11:43 pm

Thanks Alec,
I'm a newbie at PHP...so could you tell me in more detail where to put this line?

Gr. Edwin



asmecher wrote:Hi Edwin,

You'll need to find a way to increase the memory setting; you may be able to accomplish this by adding the following line near the top of OJS's index.php:
Code: Select all
ini_set("memory_limit", "16M")
Regards,
Alec Smecher
Open Journal Systems Team
Edwin
 
Posts: 3
Joined: Mon May 22, 2006 6:27 am

Postby Edwin » Tue May 23, 2006 3:48 am

Dear Alec,
Forget my last question...I should have checked the PHP-documentation....

Your solution is simply GREAT!!! It works and it saves me a lot of trouble, so great and thanx,

Gr. Edwin

Edwin wrote:Thanks Alec,
I'm a newbie at PHP...so could you tell me in more detail where to put this line?

Gr. Edwin



asmecher wrote:Hi Edwin,

You'll need to find a way to increase the memory setting; you may be able to accomplish this by adding the following line near the top of OJS's index.php:
Code: Select all
ini_set("memory_limit", "16M")
Regards,
Alec Smecher
Open Journal Systems Team
Edwin
 
Posts: 3
Joined: Mon May 22, 2006 6:27 am


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 3 guests