You are viewing the PKP Support Forum | PKP Home Wiki

Locale Portuguese

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Locale Portuguese

Postby rafaelmr » Thu Feb 02, 2006 10:58 am


I get the locale file to portuguese (pt_BR) and extract it. I update the file registry/locales.xml adding the follow lines:

<locale key="pt_BR" name="Portugues"/>

But in the system configuration (Languages Settings) don't appear the language pt_BR. On "Install Languanges" it shows the message "No additional locales are available for installation.".

Anybody can help me?

Rafael Raposo
Cadernos de Saúde Pública / Fiocruz / Brazil
Posts: 13
Joined: Fri Jan 06, 2006 10:50 am

Postby asmecher » Thu Feb 02, 2006 2:14 pm

Hi Rafael,

Your registry/locales.xml file should look like:
Code: Select all
        <locale key="en_US" name="English"/>
        <locale key="pt_BR" name="Português (Brasil)"/>
Unless I've misunderstood your comment, you've added an extra <locales> ... </locales> tag.

If this doesn't work, check to ensure that your locales/cache directory (particularly locales/cache/locales.inc.php) is writable by your web server.

Then log in as site administrator and check out the site-wide languages page -- note that each journal has a languages page too, but you'll need the Site Administrator's language page specifically.

Alec Smecher
Open Journal Systems Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby rafaelmr » Fri Feb 03, 2006 4:55 am

Hi Alec,

I really have added an enxtra <locales>...</locales> tag.

Posts: 13
Joined: Fri Jan 06, 2006 10:50 am

Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests