OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



No input file specified.

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

No input file specified.

Postby todd » Thu Sep 15, 2005 3:18 pm

The OJS site we installed was running perfectly until out of the blue...I get this ...."No input file specified" after I click on the main URL...

Any ideas?
todd
 

Re: No input file specified.

Postby asmecher » Fri Sep 16, 2005 3:36 pm

Hi Todd,

This is probably a web server/PHP configuration issue rather than an OJS issue... To verify, try placing a test.php file in the OJS root directory, containing something like:

Code: Select all
<?php
echo "Test\n";
?>


See if you can successfully view it.

Regards,
Alec
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby Todd » Mon Sep 19, 2005 8:55 am

yeah, it was my host...it changed to cgi ...but they helped me change it back....thanks
Todd
 

Re: No input file specified.

Postby asmecher » Mon Sep 19, 2005 9:49 am

FYI, OJS should also work with PHP scripts running via CGI.

Regards,
Alec
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Have same problem

Postby Guest » Mon Oct 10, 2005 4:01 pm

I have the same problem "No input file specified'. The test.php works. What can be the problem?

Sincerely,

Nabil El-Khodari
webmaster at nilebasin dot net
http://nilebasin.net/ojs/
Guest
 

Postby asmecher » Tue Oct 11, 2005 3:24 pm

Hello Nabil,

Check to see that the directory and file permissions are set appropriately, and that test.php is working from the same directory as the index.php for OJS. A google search suggests that this is a server configuration issue (most likely PHP), and that some users have had some success by changing the doc_root parameter in PHP's php.ini file.

See for example http://wordpress.org/support/topic/4243.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Thu Oct 13, 2005 9:27 am

Hello Nabil,

Also check the following from docs/FAQ:

On PHP 4 it may be necessary to add "cgi.fix_pathinfo = 1" to the server's php.ini to avoid fatal "No input file specified" errors. This parameter is enabled by default on PHP 5.


Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 2 guests