OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Displaying PDF in Internet Explorer

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Displaying PDF in Internet Explorer

Postby arnost » Mon Mar 22, 2004 3:21 pm

I had problems displaying PDF files with Internet Explorer + Acrobat Reader in Microsoft Windows (Mozilla in Linux works).

Standard behaviour: click on PDF -> file is displayed in Expolorer window.

OJS behaviour: Explorer asked what I want to do with this file (Open, Save...) If I chose Open, Acrobat Reader is launched (in new window).
Acrobat Reader tried to open file, but it only displayed error "File Not Found"!


Here is my solution:
I changed one line in include/getdoc.php
There was:
header("Content-Disposition: attachment; filename=\"...
I changed to:
header("Content-Disposition: inline; filename=\"...
It works now.


(I looked on headers from http://www.math.washington.edu/~ejpecp/ - site which displays PDF well)

Does Internet Explorer displays your PDF files? Should I change 'attachment' to 'inline'? Or it is only problem with my web-server?

Arnost
arnost
 
Posts: 5
Joined: Thu Jan 22, 2004 2:27 am

Re: Displaying PDF in Internet Explorer

Postby jkeisers » Wed Jul 28, 2004 3:17 pm

arnost wrote:
Here is my solution:
I changed one line in include/getdoc.php
There was:
header("Content-Disposition: attachment; filename=\"...
I changed to:
header("Content-Disposition: inline; filename=\"...
It works now.


Thanks a lot. I had the same problem with web-viewable files like PDF. This solved it.
jkeisers
 
Posts: 19
Joined: Wed Jul 21, 2004 9:13 pm
Location: Rutgers University, NJ, USA


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Google [Bot] and 6 guests