OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Email works only for certain addresses.

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Email works only for certain addresses.

Postby zhengu » Fri Jul 08, 2005 12:07 pm

I recently installed OJS 2 on a Mac OS 10.2.8 (Darwin). I'm having trouble with the email function. It sends emails to some addresses but not others. As an admin, I was able to send to my work email but not to yahoo or gmail accounts.

please help
thank you
Zhen
zhengu
 
Posts: 2
Joined: Fri Jul 08, 2005 11:47 am

Postby kevin » Fri Jul 08, 2005 9:19 pm

As a test you might want to verify that mail can be sent from the command-line (e.g., "mail you@example.com"). If this fails than it is not an OJS issue (check your mail logs in /var/log).

I know on Mac OS X 10.3 and later you need to enable the Postfix daemon to be able to send outgoing mail. IIRC 10.2.x uses sendmail rather than Postfix -- I don't recall specifically but I imagine on 10.2.x you do need to configure sendmail before outgoing mail can be sent.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Postby zhengu » Thu Jul 14, 2005 2:14 pm

the mail from command line only works for my work email as well. This is probably not a OJS problem but do you have any other ideas?

i sent one to my work email: zgu@mednet.ucla.edu and it works.
i sent another one to: zgu@ucla.edu, and I didn't receive it. Below is the log for the 2 emails:

Jul 14 13:58:05 IDTU-X sendmail[599]: j6EKw5E6000599: from=admin, size=50, class=0, nrcpts=1, msgid=<2005 07142058.j6EKw5E6000599@IDTU-X>, relay=admin@localhost
Jul 14 13:58:05 IDTU-X sendmail[599]: j6EKw5E6000599:
to=zgu@mednet.ucla.edu, ctladdr=admin (504/20), del ay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30042, relay=localhost [127.0.0.1], dsn=2.0.0, stat=Sent (OK)

Jul 14 13:59:47 IDTU-X sendmail[610]: j6EKxl7o000610: from=admin, size=53, class=0, nrcpts=1, msgid=<2005 07142059.j6EKxl7o000610@IDTU-X>, relay=admin@localhost
Jul 14 13:59:47 IDTU-X sendmail[610]: j6EKxl7o000610: to=zgu@ucla.edu, ctladdr=admin (504/20), delay=00:0 0:00, xdelay=00:00:00, mailer=relay, pri=30035, relay=localhost [127.0.0.1], dsn=2.0.0, stat=Sent (OK)

I've also tried to configure sendmail with the link you provided but it still does the same thing.

thanks
Zhen
zhengu
 
Posts: 2
Joined: Fri Jul 08, 2005 11:47 am

Postby kevin » Thu Jul 14, 2005 9:27 pm

If your server is running on a residential ISP it may be that the receiving SMTP server is rejecting emails from your host, as many are configured to reject emails from dynamic IPs.

If that's the case you may want to configure your local sendmail MTA to relay mail through your ISPs SMTP server.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 2 guests