OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



session.inc.php problem

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

session.inc.php problem

Postby Guest » Tue May 17, 2005 2:16 pm

Hi,
Before I get to my problem, I just wanted to thank y'all for publishing OJS. It's truly a spectacular system.
So the basic problem is that I get these errors on the main page:
Warning: ini_set(): A session is active. You cannot change the session module's ini settings at this time. in /var/www/localhost/htdocs/ojs/include/session.inc.php on line 42
Warning: ini_set(): A session is active. You cannot change the session module's ini settings at this time. in /var/www/localhost/htdocs/ojs/include/session.inc.php on line 43

They don't seem to appear anywhere else.
I can remove them by commenting out those lines in session.inc.php:
// ini_set('session.save_handler', 'user');
// ini_set('session.serialize_handler', 'php');

Nevertheless, I'd rather not start randomly chopping lines out of the system! I've made a few modifications to the pages, adding a search bar up top, and RSS feeds to the right, so it's possible I just messed up a line accidentally, although I've tried replacing index.php with an original and the problem doesn't go away.
The site's at http://www.copyrightjournal.org/ojs if it helps.
Thanks,
Ari
Guest
 

Postby kevin » Tue May 17, 2005 10:02 pm

Check if you have session.auto_start enabled in your php.ini configuration. OJS requires this option to be disabled (which is the default).
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Postby Guest » Wed May 18, 2005 7:22 am

kevin wrote:Check if you have session.auto_start enabled in your php.ini configuration. OJS requires this option to be disabled (which is the default).


There are three php.ini's on the system:
/etc/php/cli-php4/php.ini
/etc/php/apache2-php4/php.ini
/etc/apache2/conf/php.ini

All three files show:
php.ini:session.auto_start = 0

so should be disabled.
Guest
 

Postby Guest » Wed May 18, 2005 12:50 pm

So my last response was a little unclear. Just to correct that, I didn't make any changes, because it seem to already be disabled, and thus still would appreciate any assistance you can give.
Thanks,
Ari
Guest
 

Session problems

Postby ramon » Tue Oct 25, 2005 7:24 am

Ari,

Sorry to be so late..

I believe session.auto_start=Off, not 0, should be the value..
ramon
 
Posts: 931
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Postby cxd » Wed Jan 25, 2006 11:19 am

No, session.auto_start is boolean.. 1 or 0.

Im having the same problem on a system I made myself that uses adodb session handling.. I found this googling around.. If I fix it, I'll post back.
cxd
 
Posts: 2
Joined: Wed Jan 25, 2006 11:17 am

Postby cxd » Wed Jan 25, 2006 11:19 am

3 years later... lol
cxd
 
Posts: 2
Joined: Wed Jan 25, 2006 11:17 am

Postby asmecher » Wed Jan 25, 2006 12:07 pm

Hi Ari,

I hope you're not still encountering the same problem after three years! If so, a bit of googling shows some possible solutions aside from the usual session auto_start problem in docs/FAQ:Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 1 guest