OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Missing pages / wrong urls in version 1.1.8 ?

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Missing pages / wrong urls in version 1.1.8 ?

Postby khflyum » Mon Nov 01, 2004 3:07 am

We belive to have run into bugs in the 1.1.8 release.

What we see is this.

Minor problems
1) On the page : /ojs/submissions.php#guidelines
The link Author Guidelines seem to point directly to the right page, but missing the full path.

Serious problems
1) On the page: /ojs/admin/editor/sectionadmin.php?id=1&rowstart=0
When submitting this page, we get the following error:

Not Found

The requested URL /ojs/admin/editor/admin/editor/sections.php was not found on this server.

This kind of error popps up at a number of places.

What we have tried:

We have installed an new journal from the same source, the installation went without any problems, but it displayed the exact same errors when tested.

Any hints ?
If anybody prefers email we can be contacted at khflyum@ulrik.uio.no

K.H.Flyum & T. Christiansen
khflyum
 

Postby kevin » Mon Nov 01, 2004 11:50 pm

A couple of users have experienced problems with a bit of code in OJS that tries to dynamically determine the URL... You may want to try removing the block of code in include/common.php that begins:

Code: Select all
// Kludge to define base URL dynamically


and see if that resolves this issue.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Major problem solved, minor problem still there

Postby khflyum » Tue Nov 02, 2004 2:47 am

Thank you.

The major problem seem to have been solved by changing the code as you suggested. The minor (single occurence) problem seem to still be there.

The page in question is: ojs/submissions.php#guidelines

The page has a link to itself: outlined in the _Author Guidelines_ found in

When we look at the generetad code we find that this link is set as:

outlined in the <a href="../../submissions.php#guidelines" target="_blank">Author Guidelines</a> found in

the ../../ part seems to generate the error , as this places us 2 steps above the correct folder.

As this seems to come from a database query we have not tried to follow it all the way home ..

K.H.Flyum & T. Christiansen
khflyum
 

Postby kevin » Tue Nov 02, 2004 9:14 am

Are you referring to the "submission checklist" items? The default text for one of the checklist items uses "../../submissions.php#guidelines" (since it's linked from one of the author submission pages), but I can see that that would break the link when displayed on the submission guidelines page. You may want to just edit the link in the journal setup to contain a complete URL.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Ok

Postby khflyum » Wed Nov 03, 2004 7:23 am

Yes, I was.

System is now up and running.
Thank you very much for your help.

T. Christiansen
khflyum
 

Missing pages / wrong urls / No input file specified

Postby rsshaw » Sat May 07, 2005 1:24 pm

We ran into this wrong URL problem also. In our case the symptom was a page with just the message "No input file specified." Looking closely at the URL, it had duplicate directory pieces. For instance, what should have been "/admin/author/step2.php" was actually "/admin/author/admin/author/step2.php".

Removing the "Kludge to define base URL dynamically" as suggested fixed these problems. I note the code says "Probably will not work if using PHP CGI" and that our PHP configuration (which we can't control) has the option "with-cgi".

One question I have is what functionality was removed by taking out the "define base URL dynamically" code?
rsshaw
 
Posts: 7
Joined: Tue Jan 25, 2005 6:23 pm
Location: Cupertino, Calif


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 3 guests