OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



'Browse by Author' not working

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

'Browse by Author' not working

Postby emilymfg » Sun Oct 06, 2013 2:27 pm

Hello, me again! This time there seems to be something odd with the 'Browse by Author' search dialog.

All of the uploaded articles seem to have the correct metadata etc., but only a few authors seem to show up in the 'Browse by Author' window (and when 'all' is selected, they don't all appear either). The url for our journal is here: http://ojs.ucd.ie/index.php/ijamcp/index

'Browse by Title' and 'Browse by Issue' seem to work fine?

Any help would be appreciated! Thanks :)

Emily
emilymfg
 
Posts: 11
Joined: Fri Oct 04, 2013 3:24 pm

Re: 'Browse by Author' not working

Postby asmecher » Mon Oct 07, 2013 8:21 am

Hi Emily,

There's 24-hour cache used for that list, so if you've been working with content recently, either clear the cache manually or wait for it to expire; the missing authors should show up then.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: 'Browse by Author' not working

Postby emilymfg » Mon Oct 07, 2013 3:39 pm

Hello Alec, how do I clear the cache manually? Do you mean the browser cache?

Also, another related question -- I created our article PDFs from InDesign, yet none of their text seems to show up when a 'full text' search is run. Do you know why this would be?

thank you! Emily
emilymfg
 
Posts: 11
Joined: Fri Oct 04, 2013 3:24 pm

Re: 'Browse by Author' not working

Postby asmecher » Mon Oct 07, 2013 3:44 pm

Hi Emily,

See http://pkp.sfu.ca/ojs/docs/userguide/2.3.3/siteAdministrationSessionsCaches.html for information on clearing the caches. As for the PDF searching, best to continue that conversation at http://pkp.sfu.ca/support/forum/viewtopic.php?f=2&t=10717 rather than splitting it here.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: 'Browse by Author' not working

Postby emilymfg » Mon Oct 07, 2013 3:51 pm

Thanks Alec.

However I just tried clearing the data cache, and that still didn't work. It also seems odd that if I click on 'all' in the Browse Author Index, it doesn't show all of the authors who appear if I click the various letters of the alphabet?

Also I have seem to have figured out that my PDFs (created on InDesign) are already readable (I asked on the Adobe help pages), which made me think the problem might not be the pdfs, but the search function... anyhow if you have any insight, you might respond on the other thread? Thanks again, this is all a big learning curve for me :)
emilymfg
 
Posts: 11
Joined: Fri Oct 04, 2013 3:24 pm

Re: 'Browse by Author' not working

Postby asmecher » Mon Oct 07, 2013 3:58 pm

Hi Emily,

Check your web server's error log -- some of the author index letter pages appear to be truncated, which usually indicates there's an error.

There are lots of threads on the forum about setting up PDF indexing; see e.g. http://pkp.sfu.ca/support/forum/viewtopic.php?f=2&t=621.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests