You are viewing the PKP Support Forum | PKP Home Wiki

Problem installing OJS 1.1.7

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Problem installing OJS 1.1.7

Postby Borja » Wed Aug 04, 2004 10:13 am

I have just installed OJS 1.1.7 on my ISP server, It is a linux, apache, mysql, php server, and I guess they use virtual hosts for the domains.
After installing i go into login.php fill in it and i receive a "Not page found" HTTP 404 error. I realised that I may access Home, Current, About, Notify, Contact and Search sections but no Archive and Login (although I am addressed to It after installation steps, after this time I never can access it again). It is very strange, all the files are correctly uploaded on the server (I've done it twice), the database is correctly created, but everytime i try to acces those sections i've got 404 errors (the files are there!!!, I can see them on my ftp program). I even installed diferent versions: 1.1.6 and 1.1.7 having the same problem.

In the final step of the installation process i have noticed something strange. The message says that I need to set some directories so that the server can write to them (see below) but these directories do not exit in my server. The root directory of my server contains de directories: cgi-bin, data, errors, html (web directory) and logs. But there is no either fcgi-bin/images/custom nor fcgi-bin/images/articleimages. How can it say they are "currently writeable"?

I would appreciate it if someone could help me, whether here or in by email.
Borja Gonzalez
Email: borja d-o-t gonzalez a-t formatex d-o-t org

Final Instructions

Congratulations, installation of Open Journals Systems is nearly complete. To ensure proper operation of your journal web site, the following directories need to be set so that the web server can write to them:
/var/www/vhost/DOMAIN.org/fcgi-bin/images/custom (currently writeable)
/var/www/vhost/DOMAIN.org/fcgi-bin/images/articleimages (currently writeable)

Postby kevin » Wed Aug 04, 2004 10:05 pm

Looks like your server is running PHP as a CGI (specifically, through FastCGI) and not as an Apache module. This causes PHP to set some server variables (like SCRIPT_FILENAME) to the path of the PHP binary and not the script.

You should be able to fix the erroneous redirects by deleting the block of code from include/common.php:
Code: Select all
if(isset($_SERVER['SCRIPT_FILENAME']) && isset($_SERVER['SCRIPT_NAME']))

and relying on the static URL defined in the chBaseURL field in the tbljournalconfig table.
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

It worked

Postby Borja » Thu Aug 05, 2004 3:19 am

It worked!!!! Thank you very much Kevin, I solved it in 3 minutes, I should learn more php to avoid wasting time guessing things.

Thank you very much.

Postby klaas » Wed Jul 06, 2005 5:37 am

can anyone tell me what the solution for a likewise problem would be for ojs 2.0 ?

Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Google [Bot] and 3 guests