OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Support of PHP 5.4 and MySQL 5.5

OCS development discussion, enhancement requests, third-party patches and plug-ins.

Moderators: jmacgreg, michael

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Support of PHP 5.4 and MySQL 5.5

Postby roball » Thu Feb 13, 2014 12:43 pm

Does the current 2.3.x release work well also with more current versions of PHP and MySQL, in particular with PHP 5.4.x and MySQL 5.5.x?
roball
 
Posts: 50
Joined: Wed Mar 21, 2012 1:43 pm

Re: Support of PHP 5.4 and MySQL 5.5

Postby asmecher » Thu Feb 13, 2014 1:06 pm

Hi roball,

As far as I'm aware, yes; if you have trouble, please let me know and I'll look into it ASAP.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Support of PHP 5.4 and MySQL 5.5

Postby roball » Thu Feb 13, 2014 2:31 pm

Thanks for confirming. Just wanted to ensure before I will update to those versions because another web based software (Moodle 2.7) I am planning to update to will have these minimum requirements.

I realized I had to apply the patch from http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=7544 to support PHP 5.4. Are there any other patches that must be applied so OCS will still work after updating PHP from 5.3 to 5.4?
roball
 
Posts: 50
Joined: Wed Mar 21, 2012 1:43 pm

Re: Support of PHP 5.4 and MySQL 5.5

Postby roball » Thu Feb 05, 2015 12:40 pm

Just "for the log", I can confirm that the stock OCS 2.3.6 version works perfectly fine with php 5.4 and mysql 5.5.
roball
 
Posts: 50
Joined: Wed Mar 21, 2012 1:43 pm


Return to OCS Development

Who is online

Users browsing this forum: No registered users and 1 guest