OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Website/Conference Setup

Are you a Director, Presenter, Reviewer or Conference Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael

Forum rules
This forum is meant for general questions about the usability of OCS from an everyday user's perspective: conference managers, presenters, and directors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OCS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OCS:

1. Read the documentation. We've written documentation to cover from OCS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OCS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OCS Technical Support subforum; if you have a development question, try the OCS Development subforum.

Website/Conference Setup

Postby gdardick » Sat Jan 30, 2010 9:22 pm

I have updated the Website setup to change the footer. I have also updated the conference setup to change the submission guidelines.

However in both cases, even though the fields were updated, the pages are not reflecting the changes. I've looked through the database (MySql) and saw the changes and I searched the website pages (source) - but cannot figure out why the changes are not being shown on the pages.

Thanks.

Glenn
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby jamief » Sun Jan 31, 2010 7:45 am

Have you tried entering as admin and emptying the caches?
jamief
 
Posts: 140
Joined: Sun May 31, 2009 2:49 am

Re: Website/Conference Setup

Postby gdardick » Sun Jan 31, 2010 7:54 am

I logged in as myself and entered "Site Administration". I then cleared template and data caches. Is that what you meant? (It didn't update the fields on the pages).

Is there an "Admin" user id?
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby gdardick » Sun Jan 31, 2010 8:04 am

I even tried replacing t_compile and _db directories manually (t_cache was empty) as they weren't being cleared out when I tried using the system. Still no effect.

Glenn
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby jamief » Mon Feb 01, 2010 6:51 am

I think to say anything more I would have to see the site, and you might explain what changes you say you made in those files that are not being reflected in the final display (including the names of the files you edited.
jamief
 
Posts: 140
Joined: Sun May 31, 2009 2:49 am

Re: Website/Conference Setup

Postby gdardick » Mon Feb 01, 2010 10:25 am

I guess at a minimum it would be safe to look at the first page - http://ocs.digitalforensics-conference.org.

At the bottom, there is a 2009 copyright as follows:
(c) 2009 Association of Digital Forensics, Security and Law (ADFSL).

I have changed this to:
(c) 2010 Association of Digital Forensics, Security and Law (ADFSL)

under the following
Conference Site Management > Website Management > 3.3 Website Footer
This is the footer of your conference. To change or update the footer, paste the HTML code in the textbox below. Examples could be another navigation bar, a counter, etc. This footer will appear on every page.

but the new correct info is in that form but never shows on the page.
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby jamief » Tue Feb 02, 2010 2:05 am

Hi again.

Okay. I see when you mean make changes, you are talking about modifications in content using the system directly. Fine.
Here is what I suggest you think about first.

In OCS and equally in OJS there are two levels of display: The OCS as a Conference System, and each individual conference.

I suggest that probably what is happening is you are changing the footer in ONE of those areas, but it needs to be in the other.

i.e. when you FIRST enter in as admin, you have two levels of rights: the system wide admin, and admin of each and every conference.

Perhaps you have been working at the lever of admin of conference 2010, but you need to enter as system admin and edit the SYSTEM WIDE footer in this case.
(or vice versa - you are making footer changes to the SYSTEM and you need to make footer changes to the individual conference - first entering into hosted conferences and then into the admin function of the conference.) One way to see the difference is to have a separate login for the 2010 conference and enter using that, that way you won't have access to higher level editing and won't be confused as to where you are at any given moment as admin gives you too much to work with on a daily bases.)

This is where I would start.
jamief
 
Posts: 140
Joined: Sun May 31, 2009 2:49 am

Re: Website/Conference Setup

Postby gdardick » Tue Feb 02, 2010 7:32 am

This may be a clue, but I can't even change the theme. It changes on the form, but the pages still have the theme originally selected.
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby jamief » Tue Feb 02, 2010 12:12 pm

Looks to me like you found the issue, I see your page now redirects immediately to the conference, and shows a modified 2010 footer.
jamief
 
Posts: 140
Joined: Sun May 31, 2009 2:49 am

Re: Website/Conference Setup

Postby gdardick » Tue Feb 02, 2010 12:24 pm

it was the permissions. templates weren't being reset.

thanks!
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby gponceba » Mon May 10, 2010 12:26 pm

Please,

It is exactly the same problem after upgrade to OCS 2.3.1, buy only with Additional Content in Website Management (Step 2).

Even though the field were updated, the scheduled conference page are not reflecting the changes. I've looked through the database (MySql) and saw the changes and I searched the website pages (source) - but cannot figure out why the changes are not being shown on the page.

I'm giving a thousand rounds (database, index.tpl, permissions, ...) and I can't find the problem.

Can you help me?

Cheers.
gponceba
 
Posts: 8
Joined: Mon May 10, 2010 7:48 am

Re: Website/Conference Setup

Postby gdardick » Mon May 10, 2010 12:37 pm

I can't remember what I did exactly (sorry) - but initially to test I set the permissions of the template and cache folders for everybody with everything set to allow (that was on Windows). Then I selected the option to delete the templates and/or cache under the site administration option. Those were the following:

Clear Data Caches
Clear Template Cache

Not a very secure test - sorry - but it did work.
gdardick
 
Posts: 27
Joined: Sun Sep 13, 2009 3:58 am

Re: Website/Conference Setup

Postby gponceba » Mon May 10, 2010 12:44 pm

Thanks gdardick,

but I had already tried all that too.

- Folder 'cache' and subfolders with permissions 777
- Clear Data Caches & Clear Template Cache many times

Is that the thing is very rare, rare... I don't understand :S

It only happens with that field.......
gponceba
 
Posts: 8
Joined: Mon May 10, 2010 7:48 am

Re: Website/Conference Setup

Postby jmacgreg » Wed May 12, 2010 10:33 am

HI gponceba,

I have replicated this issue and filed a bug report: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5430. Please feel free to CC yourself to that for future updates.

Cheers,
James
jmacgreg
 
Posts: 4181
Joined: Tue Feb 14, 2006 10:50 am


Return to OCS Conference Support and Discussion

Who is online

Users browsing this forum: No registered users and 3 guests