We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 8811 - Announcement emails need work
Announcement emails need work
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
1.1.1
All All
: P3 normal
Assigned To: Michael Thessel
: 8930 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-19 10:53 PDT by Alec Smecher
Modified: 2015-01-09 16:27 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Alec Smecher 2014-06-19 13:57:50 PDT
Over to you for review, Michael.
Comment 2 Alec Smecher 2014-06-19 13:58:02 PDT
Pull request opened (not merged):
Fix new announcement notification email
https://github.com/pkp/pkp-lib/pull/110
Comment 3 Michael Thessel 2014-06-23 15:03:58 PDT
Reviewed and merged.
Comment 4 Alec Smecher 2014-06-23 15:05:03 PDT
Fix announcement mailout URL
https://github.com/pkp/pkp-lib/commit/31c27cb16512cf958a3a56a4aa0da4917bc4cec8
Comment 5 Alec Smecher 2014-06-23 15:05:03 PDT
Missing locale key
https://github.com/pkp/pkp-lib/commit/9794368f1124c217a2d03e6bb573570fe30b984c
Comment 6 Alec Smecher 2014-06-23 15:05:03 PDT
Notifications should not be emailed on update of existing announcement
https://github.com/pkp/pkp-lib/commit/3c1e872921074030a62051c7bb0cb6f201c13518
Comment 7 Alec Smecher 2014-06-23 15:05:03 PDT
Pull request closed (merged):
Fix new announcement notification email
https://github.com/pkp/pkp-lib/pull/110
Comment 8 Alec Smecher 2014-09-30 09:05:10 PDT
*** Bug 8930 has been marked as a duplicate of this bug. ***
Comment 9 Alec Smecher 2015-01-09 16:27:08 PST
Note: This bug never got back-ported to OMP in time for the 1.1.1 release. To apply it to the OMP 1.1.1 tarball, apply both...

https://github.com/pkp/pkp-lib/commit/36c4149df39a071fae54bf87573806e56f001ef6
https://github.com/pkp/omp/commit/da7c70803b0e0e8bd5f685a97b9aa97c0d43c197

It's been committed to the omp-stable-1_1_1 branch.