Bug 8637 - User group stage assignment is too much complicated
User group stage assignment is too much complicated
Status: RESOLVED FIXED
Product: PKP-LIB
Classification: Unclassified
Component: User Interface
Undetermined
All All
: P3 normal
Assigned To: PKP Support
: 7515 8331 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-20 16:12 PDT by beghelli
Modified: 2014-08-27 06:50 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description beghelli 2014-03-20 16:12:34 PDT
It's too much difficult to figure out what we need to do to toggle the stage assignments for user groups. The list repeats user groups and also don't allow to delete created ones.
Comment 1 beghelli 2014-03-20 16:15:02 PDT
Fix user groups stage assignment interface
https://github.com/pkp/pkp-lib/commit/d8f96f4249c18749e5bbd7bc20361332779c33af
Comment 2 beghelli 2014-03-20 16:16:02 PDT
Submodule changes track
https://github.com/pkp/omp/commit/485ca97371b7b544ee74f9149b1f742883ad128d
Comment 3 beghelli 2014-03-20 16:21:02 PDT
Submodule track changes
https://github.com/pkp/omp/commit/be2183d2c59404c491a580a82af0457d4860fa81
Comment 4 beghelli 2014-03-20 16:22:02 PDT
Fix user groups stage assignment interface
https://github.com/pkp/pkp-lib/commit/9495c3a785479264068b53a3876cebdda4791ff4
Comment 5 beghelli 2014-03-20 16:43:02 PDT
Fix non existing class import and moved filter template file
https://github.com/pkp/pkp-lib/commit/b0f0efc6089fc74b8f6727db59e572ac51076c56
Comment 6 beghelli 2014-03-20 16:45:02 PDT
Fix non existing class import and moved filter template file
https://github.com/pkp/pkp-lib/commit/5e56d94a0200a172cacbbb68657db27f7907ed28
Comment 7 beghelli 2014-03-20 16:47:01 PDT
Submodule changes track
https://github.com/pkp/omp/commit/4f8af684568770cab892540f2fc200442f4a443d
Comment 8 beghelli 2014-03-20 16:48:02 PDT
Submodule changes track
https://github.com/pkp/omp/commit/9aa4253a7c7c6526ab51c127fda13a8d17c438c8
Comment 9 beghelli 2014-03-20 16:51:03 PDT
Submodule changes track
https://github.com/pkp/ojs/commit/184d43a16406c5b3dfa748d32ae2bdcab2ca43e7
Comment 10 Alec Smecher 2014-04-10 09:04:13 PDT
*** Bug 7515 has been marked as a duplicate of this bug. ***
Comment 11 Alec Smecher 2014-04-10 09:12:35 PDT
*** Bug 8331 has been marked as a duplicate of this bug. ***