Bug 8517 - database error in editor submissions page. DB Error: Unknown column 'ea.user_id' in 'where clause'
database error in editor submissions page. DB Error: Unknown column 'ea.user_...
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.4.x
All All
: P3 normal
Assigned To: PKP Support
: 8154 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-17 06:59 PST by Carlos Cesar Caballero Diaz
Modified: 2014-08-19 09:02 PDT (History)
4 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Cesar Caballero Diaz 2013-12-17 06:59:39 PST
In the editor submission pages, Unassigned, In Review, or In Editing, when I select: assigned to my. A db error is displayed (DB Error: Unknown column 'ea.user_id' in 'where clause') and the submission page becomes unavailable.
Comment 1 Carlos Cesar Caballero Diaz 2013-12-17 07:33:57 PST
problem solved (well, I think...)
in classes/editor/EditorSubmissionDAO.inc.php
in the _getUnfilteredEditorSubmissions function, change:

$searchSql .= ' AND ea.user_id = ?';

by:

$searchSql .= ' AND ea.editor_id = ?';
Comment 2 Alec Smecher 2013-12-17 08:44:55 PST
*** Bug 8154 has been marked as a duplicate of this bug. ***
Comment 3 Clinton Graham 2014-08-19 07:06:15 PDT
Should be marked resolved per https://github.com/pkp/ojs/commit/3d3925d0b58dde6068466601e40083dcce86fb82
Comment 4 Alec Smecher 2014-08-19 09:02:45 PDT
Yes -- thanks, Clinton.