Bug 8470 - Crossref export reported as faulty when submitted to Crossref
Crossref export reported as faulty when submitted to Crossref
Status: RESOLVED DUPLICATE of bug 8412
Product: OJS
Classification: Unclassified
Component: Open Journal Systems
2.4.x
All Linux
: P3 major
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 06:11 PST by hilton.gibson@gmail.com
Modified: 2013-11-14 06:05 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Example submission (30.45 KB, text/xml)
2013-11-07 06:11 PST, hilton.gibson@gmail.com
Details
Patch against OJS 2.4.2 (2.09 KB, patch)
2013-11-14 01:09 PST, hilton.gibson@gmail.com
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hilton.gibson@gmail.com 2013-11-07 06:11:08 PST
Created attachment 3972 [details]
Example submission

Several attempts to submit the exported Crossref file to Crossref results in errors even though Crossref accepts the submission.
Comment 1 Jason Nugent 2013-11-07 06:20:24 PST
Hilton,

I'm not sure this is a bug. Your included XML has DOIs for articles, but not for issues.  Have you assigned DOIs to your issues?  

Jason
Comment 2 Michael Nason 2013-11-07 10:29:50 PST
Hey Jason,

I believe this might be related to this bug:

http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8412

We just patched the same thing here. The DOI Plugin was creating empty DOI elements regardless of whether or not the journal used DOIs on an issue basis. Everything worked fine post-patch.
Comment 3 Jason Nugent 2013-11-08 06:18:38 PST
Hilton,

Can you try Michael's suggestion and apply the patch in the bug report he linked to?

Regards,
Jason
Comment 4 hilton.gibson@gmail.com 2013-11-14 01:09:33 PST
Created attachment 3973 [details]
Patch against OJS 2.4.2

Applied the patch to: http://aps.journals.ac.za and Crossref DOI submissions works without errors.
Comment 5 hilton.gibson@gmail.com 2013-11-14 01:17:24 PST
This wiki page needs updating when the bug fix is confirmed.

http://pkp.sfu.ca/wiki/index.php?title=OJS_2.4.2_Recommended_Patches
Comment 6 Jason Nugent 2013-11-14 06:05:05 PST
Thanks, Hilton.  Patch list updated, and this bug has been marked as a duplicate of the original report

*** This bug has been marked as a duplicate of bug 8412 ***