Bug 8459 - change forgot password from 2 steps to 1 step
change forgot password from 2 steps to 1 step
Status: RESOLVED DUPLICATE of bug 8599
Product: OJS
Classification: Unclassified
Component: General
3.0
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 09:07 PDT by Juan Pablo Alperin
Modified: 2014-03-11 10:03 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Pablo Alperin 2013-10-28 09:07:51 PDT
It confuses a LOT of people to have two emails necessary for lost passwords. Plus, they require sending the password in an email, which is probably not a best practice. 

We should be able to use the token functionality already in OJS now to change this to a single email, with the following steps: 

1) Request Password reset
2) Receive email with link to confirm password reset. Link should contain login token. Account should force changing password on login.
3) User arrives at screen requesting new password.
Comment 1 Jason Nugent 2014-03-11 10:03:24 PDT

*** This bug has been marked as a duplicate of bug 8599 ***