We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 8439 - Journal Manager's reviewing interests search does not return results
Journal Manager's reviewing interests search does not return results
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Journal Management
2.4.4
All All
: P3 normal
Assigned To: Alec Smecher
: 8271 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 10:10 PDT by Alec Smecher
Modified: 2014-02-03 15:45 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Alec Smecher 2013-10-04 10:13:03 PDT
*** Bug 8271 has been marked as a duplicate of this bug. ***
Comment 2 Alec Smecher 2013-10-04 10:33:03 PDT
Fix JM's reviewer interest search
https://github.com/pkp/ojs/commit/3efe08c858a87b7cd2a9924b1959c215a815056f
Comment 3 Alec Smecher 2013-10-04 15:05:02 PDT
Additional fix for reviewer interest search
https://github.com/pkp/ojs/commit/eb7fdec35ca24008307076f79639cf3fe271e126
Comment 4 Riccardo Fazio 2014-01-30 05:53:23 PST
(In reply to comment #3)
> Additional fix for reviewer interest search
> https://github.com/pkp/ojs/commit/eb7fdec35ca24008307076f79639cf3fe271e126

Hi Alec,

I applied this patch against (2.4.2) and I don't get results;
I tried also with 2.4.3 fresh installation and still the "reviewing interests search" does not return any result.
I found also that if you are an editor and try a "enrollSearch" (ie. when you search for an existing user to enroll as a reviewer) you still don't get results (in 2.4.2 or 2.4.3).
In PKPUserDAO.inc.php particularly in this function "getUsersByField" you have this string_query when a "review interest search" is performed: 

SELECT DISTINCT u.* 
FROM users u,controlled_vocabs cv, controlled_vocab_entries cve, controlled_vocab_entry_settings cves 
WHERE  cv.assoc_type = '4096' cv.symbolic ='interest' 
AND cve.controlled_vocab_id = cv.controlled_vocab_id 
AND cves.controlled_vocab_entry_id = cve.controlled_vocab_entry_id 
AND LOWER(cves.setting_value) LIKE LOWER('%test%')

I think that the user_intersts table is missing, is it correct?

Thanks 
Riccardo
Comment 5 Alec Smecher 2014-01-31 15:54:10 PST
Ricardo, you're right -- it looks like at least in that one case a join is missing. Reopening.
Comment 6 Alec Smecher 2014-02-03 15:37:59 PST
Ricardo, try applying the additional patch:
https://github.com/pkp/pkp-lib/commit/1f5e8d1749db1ab192d65861dbd0f79be1414b98.diff
...from the lib/pkp subdirectory; it should correct the problem.
Comment 7 Alec Smecher 2014-02-03 15:38:02 PST
Fixed manager's enrollment search for reviewer interests
https://github.com/pkp/pkp-lib/commit/1f5e8d1749db1ab192d65861dbd0f79be1414b98
Comment 8 Alec Smecher 2014-02-03 15:45:02 PST
Fixed manager's enrollment search for reviewer interests (master branch)
https://github.com/pkp/pkp-lib/commit/847f3f0e0ecf37924e1b557e524762e9151c5e27