Bug 8408 - TOC doesn't show latest issue's data, show data of thereof which was uploaded last
TOC doesn't show latest issue's data, show data of thereof which was uploaded...
Status: RESOLVED INVALID
Product: OJS
Classification: Unclassified
Component: User Interface
2.4.x
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 06:44 PDT by Garant
Modified: 2013-09-05 22:39 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Garant 2013-08-29 06:44:23 PDT
Hi! 
In templates/index/journal.tpl there is accessible method:
$issue->getIssueIdentification()
which should retrieve the latest journal's TOC.
But it doesn't work properly when after latest issue you upload some old one's. It shows the latest which was uploaded. The back issues arrangement/sorting doesn't make any sense.
Comment 1 Alec Smecher 2013-09-05 15:59:48 PDT
Garant, this is by design; the most recently submitted issue becomes the "Current" issue, regardless of dates of publication. To change which issue is the current, go to the Editor's "Back Issues" interface and choose the current issue from the "Current Issue" dropdown. Then record the change.
Comment 2 Garant 2013-09-05 22:39:55 PDT
Hi, Alec! Thank you very much for your reply!
Yes, everything works just fine, not a bug :)