We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 8407 - Active review count on reviewer selection page incorrect
Active review count on reviewer selection page incorrect
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.4.3
All All
: P3 normal
Assigned To: Jason Nugent
: 8519 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 13:12 PDT by Chris MacDonald
Modified: 2013-12-18 09:24 PST (History)
2 users (show)

See Also:
Version Reported In: 2.3.8
Also Affects: OJS 2.4.x


Attachments
Alters the incomplete count query and the query used to sort by various columns, active count included. (6.75 KB, application/octet-stream)
2013-08-27 13:12 PDT, Chris MacDonald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris MacDonald 2013-08-27 13:12:34 PDT
Created attachment 3954 [details]
Alters the incomplete count query and the query used to sort by various columns, active count included.

The reviewer selection page that is presented to an editor contains a table of potential reviewers and a count of active reviews for each. This active review count is wrong - it includes reviews that have been declined by a reviewer as well as articles that have been declined or archived and the reviewer hasn't yet completed their review.
Comment 1 Alec Smecher 2013-09-04 16:42:12 PDT
Jason, I think you were reviewing this entry, correct?
Comment 2 Jason Nugent 2013-09-05 10:05:16 PDT
It took some doing, but I was able to test these query modifications for compliance against SQL-92 and SQL-99.  If we're cool with using != for comparison tests (the a.status test), which is valid in Postgres, then the patch looks good.  For standard compliance, we'd need to use <> instead.

I can commit Chris' work if that's fine, Alec.
Comment 3 Alec Smecher 2013-09-05 10:08:28 PDT
Better to use <> -- OTOH that's what we generally use. But otherwise, please go for it.
Comment 4 Jason Nugent 2013-09-05 10:11:27 PDT
tweak made, committed. Closing.  Thanks, Chris!
Comment 5 Jason Nugent 2013-09-05 10:12:02 PDT
fix active review counts on reviewer selection page
https://github.com/pkp/ojs/commit/bfcc2745ad9e1f39e222c54ed8307713c51175f7
Comment 6 Alec Smecher 2013-12-18 09:24:36 PST
*** Bug 8519 has been marked as a duplicate of this bug. ***