We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 8354 - "Add Files" plupload button doesn't work with Firefox 22
"Add Files" plupload button doesn't work with Firefox 22
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: Tools
1.1
All All
: P3 normal
Assigned To: beghelli
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 15:07 PDT by James MacGregor
Modified: 2013-12-19 09:06 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Screenshot (71.26 KB, image/png)
2013-09-13 16:17 PDT, James MacGregor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2013-07-30 15:07:14 PDT
Plupload's "Add Files" button doesn't seem to work in Firefox 22 (possibly others, though it does work in Chrome). Clicking it results in it blinking briefly, but nothing else. The "Drag Files Here" option does work, however, so that can be used as a temporary workaround. 

We appear to be using plupload 1.5.2. "Upgrading" to 1.5.7 by simply replacing the contents of lib/pkp/js/lib/plupload with the 1.5.7 download doesn't resolve the problem. Searching for "plupload add files button not working firefox" returns a lot of threads on the plupload forum, but the discussions are generally beyond my javascript understanding. 

See also Bug 7053.
Comment 1 Jason Nugent 2013-08-28 07:49:10 PDT
James,

The plupload2 beta fixes the problem with FF22.  I'm not sure if the fix will be backported to the 1.5.x line -- plupload2 seems to have a lot of other re-written components as well.
Comment 2 Jason Nugent 2013-08-30 10:33:02 PDT
fix 'add files' button in Firefox
https://github.com/pkp/pkp-lib/commit/33d16764e5f65469b636361311c52e63453fefa8
Comment 3 Jason Nugent 2013-09-04 11:04:01 PDT
fix 'add files' button in Firefox
https://github.com/pkp/pkp-lib/commit/2cac63c7cd0f4285a940f3faac5c15e21dd551ee
Comment 4 Jason Nugent 2013-09-04 11:08:02 PDT
fix 'add files' button in Firefox
https://github.com/pkp/pkp-lib/commit/f2396d0ad3a18e9fca8495948a757241002b897e
Comment 5 James MacGregor 2013-09-13 16:17:41 PDT
Created attachment 3958 [details]
Screenshot
Comment 6 James MacGregor 2013-09-13 16:18:13 PDT
Hi Jason, 

Sorry to reopen this -- but this appears to be broken in IE8 at least (Windows XP). I'll try on IE9/Windows 7 this weekend. At the moment in IE8 I actually can't see the plupload dialogue at all -- see attached screenshot.
Comment 7 Jason Nugent 2013-09-13 16:22:08 PDT
It's a different problem, actually. Bruno's done some IE testing and file uploading is broken in general.  This bug isn't the cause (he rolled back the commit and tested the original).  We broke something when we were doing Js Linting I think.
Comment 8 Alec Smecher 2013-11-21 16:23:18 PST
Bruno, do you mind testing file uploading with IE again, per Jason's last comment?
Comment 9 beghelli 2013-12-09 15:35:18 PST
Still not working for IE8. But works for FF, Opera and Chrome.
Comment 10 beghelli 2013-12-10 03:38:39 PST
I was wrong, it works with IE8. I needed only to install flash player. Maybe we should build a warning telling that, so users will know what they have to do.
Comment 12 beghelli 2013-12-16 14:37:02 PST
Introduce warning message for missing uploader
https://github.com/pkp/pkp-lib/commit/d782cfec60df12d658b1aa535eec686a88af57ab