Bug 8279 - Re-introduce "log in as" function
Re-introduce "log in as" function
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: General
3.0a
All All
: P3 normal
Assigned To: Michael Thessel
: 7802 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 16:06 PDT by Alec Smecher
Modified: 2014-04-10 09:22 PDT (History)
4 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2013-06-26 16:06:14 PDT
Consider re-introducing "log in as". It was broadly used and saves us having to add a lot of "editor to enter..." stuff.
Comment 1 Juan Pablo Alperin 2013-06-26 20:54:31 PDT
actually not sure if its necessary, as by default (in OMP at least) the editor can do everything the author can. And it gets marked appropriately as the editor having done it (for the record).
Comment 2 Bozana Bokan 2013-06-27 04:50:42 PDT
I think this was sometimes helpful in order to see what that other person is doing or is stuck with or to help/do something as this person and not as editor, but... I don't now the new system and user & roles functionality yet :-\, so this might be not necessary any more... :-)
Comment 3 Marco Tullney 2013-06-29 00:56:32 PDT
But it changes history… as long as there is a "log in as" function we can't tell if an action (any action) has been performed by that user. Submitting an article? Accepting final versions? Entering reviews? It just doesn't feel right.

(I know that it has been broadly used, even to simulate huge parts of the OJS submission and publishing process (by using email to communicate with reviewers, copyeditors etc. and then using OJS on their behalf). It's the editors decision to not use OJS for what it is good at, but perhaps it shouldn't be that easy to circumvent the standard workflows.)

Having a correct record is really important. OJS using OMP's approach of "editor can do it, but the action gets attributed to that editor" sounds better to me than a "log in as" function.
Comment 4 Alec Smecher 2013-07-03 10:40:03 PDT
Marco, if we were to reintroduce "Log In As", then the primary user account (not the one they're operating under) should appear in the logs. However, I agree that we might not necessarily want to re-introduce this -- but in the past it's been the only way to do some operations, so we'd need to be sure that we have full coverage.
Comment 5 Michael Thessel 2013-07-12 16:52:24 PDT
I did some research on this. In general the functionality is still there (current master). As admin you can simply call http://example.com/[journal]/login/signInAsUser/[userid] and you will be logged in as this user. What is missing is the frontend implementation.

Just to clarify the scope:
* Add a log in as button for each user on the Management > Settings > Users & Roles page. The button will show after you click on the settings pencil icon as part of the actions list. The button will only show if you are the manager of all journals the user is enrolled in (See last point).
* If you are logged in as a different user, an additional "log out as user" link will show next to your general "logout" link.
* Make sure that the logger logs activities under the actual users username and not as the user you are logged in as.
* Make sure that you can only log in as a user who is only enrolled in journals you manage (aka, don't allow changes to journals you are not manager of). 

Could you please confirm that this is all that's required?

Thanks.
Comment 6 Alec Smecher 2013-07-15 09:19:38 PDT
Michael: Yes, that's all correct. (Terminology wise: actions that can be accessed after clicking the pencil icon beside a grid row are called "row actions". This is as opposed to "grid actions", which appear at the top of the grid and are used e.g. for "add row" type activities.)
Comment 7 Michael Thessel 2013-07-26 14:35:05 PDT
Added 2 pull requests:
https://github.com/pkp/pkp-lib/pull/40
https://github.com/pkp/ojs/pull/84

I need to fix:
http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8335

before this will work correctly. Hold off with testing for now.

I used the enroll_user icon for the "log in as" row action. Not sure if this is OK. Maybe we want to use another icon or no icon. Please advise.
Comment 8 Alec Smecher 2014-04-10 09:22:11 PDT
*** Bug 7802 has been marked as a duplicate of this bug. ***