Bug 8271 - Reviewers search form returns empty results with the interests field
Reviewers search form returns empty results with the interests field
Status: RESOLVED DUPLICATE of bug 8439
Product: OJS
Classification: Unclassified
Component: Journal Management
2.4.2
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 09:15 PDT by Carlos Cesar Caballero Diaz
Modified: 2013-10-04 10:13 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Cesar Caballero Diaz 2013-06-26 09:15:47 PDT
The reviewer search form from the manager section (/manager/people/reviewers) is not working for the interests field, it always return an empty search.
It work in the 2.3.8 version and getting back the changes in the getUsersByRoleId function of the RoleDAO class seems to work properly (at least gave me the expected search results)
Comment 1 Alec Smecher 2013-06-27 12:03:26 PDT
Carlos, have you checked the user accounts that you expect to appear to see that the interests are correctly registered on those users' profiles?
Comment 2 Carlos Cesar Caballero Diaz 2013-07-01 05:41:19 PDT
Yes, I did.
I have updated from 2.3.8 to the 2.4.2 version and the problem occurred, first I thought it was a problem with the update, but later I install a clean 2.4.2, I added some users with the reviewer role, I add some revision interest tags to them and the problem continue, all revision interest search returns no matches (except when the form input is left empty and show all the reviewer users) all the other searches (by name, last name etc...) is working ok.
Comment 3 Alec Smecher 2013-07-03 11:09:53 PDT
Carlos, I did some quick testing locally and was unable to duplicate the problem. Would you be able to provide me with a test database (anonymized as much as you like) and a description of a test case?
Comment 4 Alec Smecher 2013-10-04 10:13:03 PDT
Carlos, my mistake -- I was testing this in the Reviewer interface. In the Manager interface there are indeed zero results returned. I'll attach a patch to bug #8439.

*** This bug has been marked as a duplicate of bug 8439 ***