Bug 8223 - Site Administrator css upload option doesn't work
Site Administrator css upload option doesn't work
Status: RESOLVED WORKSFORME
Product: OJS
Classification: Unclassified
Component: General
2.4.3
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-07 14:47 PDT by James MacGregor
Modified: 2013-07-03 11:06 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2013-05-07 14:47:42 PDT
Nothing seems to happen if I choose a stylesheet/css file from the Site Admin -> Site Settings page and click upload: the page refreshes, but I don't see any css file listed, and there is no file in my files_dir/site directory. Checked on two different servers now, so I don't think it's a permissions issue. Haven't tested with 2.3.x or 3.x, but am happy to.
Comment 1 Chris Burdzy 2013-06-01 21:35:39 PDT
I have installed OJS 2.4.2 a few days ago.
When I try to upload a .css file, I get the error message

" Errors occurred processing this form:

    Invalid journal stylesheet format. Accepted format is .css."

The file does have .css extension.
Comment 2 Alec Smecher 2013-06-02 09:06:09 PDT
Chris, this is likely a different issue -- it's been discussed quite a bit on the support forum; I'd suggest searching there for related conversation.
Comment 3 Alec Smecher 2013-07-03 11:06:01 PDT
James, this works OK for me; the site stylesheet should get saved in public/site/sitestyle.css -- check your file permissions on public/site.