We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 8182 - DB Error: Unknown column 'enabled' in 'on clause'
DB Error: Unknown column 'enabled' in 'on clause'
Status: VERIFIED FIXED
Product: OHS
Classification: Unclassified
Component: General
unspecified
All Linux
: P3 blocker
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-25 12:21 PDT by Fernando Ribeiro
Modified: 2013-03-25 14:11 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando Ribeiro 2013-03-25 12:21:13 PDT
After a fresh install I got this error while opening the ohs homepage.

I'm using:
 OHS 2.3.2
 MySQL 5.5.28
 Apache 2.2.12
 PHP 5.2.14
 Suse Linux Enterprise Server 11 (x86_64) 

How to fix this?





DB Error: Unknown column 'enabled' in 'on clause'

Stack Trace:

File: /srv/www/vhosts/ohs/lib/pkp/classes/site/VersionDAO.inc.php line 228
Function: DAO->retrieve("SELECT v.* FROM versions v LEFT JOIN plugin_settings ps ON ...", Array(0), False)

File: /srv/www/vhosts/ohs/lib/pkp/classes/core/PKPApplication.inc.php line 257
Function: VersionDAO->getCurrentProducts(Array(0))

File: /srv/www/vhosts/ohs/lib/pkp/classes/plugins/PluginRegistry.inc.php line 98
Function: PKPApplication->getEnabledProducts("plugins.generic")

File: /srv/www/vhosts/ohs/lib/pkp/classes/core/Dispatcher.inc.php line 126
Function: PluginRegistry->loadCategory("generic", True)

File: /srv/www/vhosts/ohs/lib/pkp/classes/core/PKPApplication.inc.php line 176
Function: Dispatcher->dispatch(Object(Request))

File: /srv/www/vhosts/ohs/index.php line 65
Function: PKPApplication->execute()
Comment 1 Alec Smecher 2013-03-25 13:45:02 PDT
Fixed double-quoted SQL
https://github.com/pkp/pkp-lib/commit/95856d44c04ef61f2ca83f67f518bbecfdebc0dd
Comment 2 Alec Smecher 2013-03-25 13:46:27 PDT
Fernando, thanks for reporting. The problem is an SQL string that's accidentally quoted with double-quotes (") rather than apostrophes ('). There's a patch linked in comment #1; apply it from within the lib/pkp subdirectory. I suspect certain versions of MySQL allow this kind of quoting (mine, for example, doesn't complain) and yours doesn't.
Comment 3 Fernando Ribeiro 2013-03-25 14:11:35 PDT
Works fine.
Thanks