Bug 8181 - Memory leak while running rebuildSearchIndex.php
Memory leak while running rebuildSearchIndex.php
Status: RESOLVED DUPLICATE of bug 6635
Product: OJS
Classification: Unclassified
Component: Search/Indexing
2.4.2
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-25 08:48 PDT by Shubhash Wasti
Modified: 2013-03-25 08:51 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shubhash Wasti 2013-03-25 08:48:05 PDT
We have a journal with around 700 articles. I found that some articles were missing in the search results, so decided run the script "rebuildSearchIndex.php". However, I found that no reasonable amount of memory is sufficient to complete the indexing.

After several tries, I ended up allowing 6GB of memory just to see how far it goes, but the script still crashed after a while. Thus I am unable to complete the indexing, and so the search is useless for this journal at the moment.

Here is the last error message from PHP:

PHP Fatal error:  Allowed memory size of 6442450944 bytes exhausted (tried to allocate 71 bytes) in /ojsdir/lib/pkp/lib/adodb/adodb.inc.php on line 818
Comment 1 Alec Smecher 2013-03-25 08:51:48 PDT
Shubhash, this is already filed in bug #6635. My suspicion is that it's a PHP issue, though I haven't investigated it thoroughly enough to be sure. Unfortunately there's very little we can do in PHP-land beyond unsetting variables.

*** This bug has been marked as a duplicate of bug 6635 ***