Bug 8139 - Uploading a Proof attachment results in proof being marked complete
Uploading a Proof attachment results in proof being marked complete
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.4.2
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-01 16:46 PST by James MacGregor
Modified: 2013-03-04 15:35 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.8 (936 bytes, patch)
2013-03-04 11:35 PST, Jason Nugent
Details | Diff
Patch against OJS 2.4 (951 bytes, patch)
2013-03-04 11:35 PST, Jason Nugent
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2013-03-01 16:46:59 PST
This concerns the "Complete" email the author sends at the end of the proofreading process. If the author clicks on the "Complete" email, and then uploads an attachment via the email template, the email actually completes/sends immediately. This means the author may not have entered any info into the mail body, or have otherwise confirmed that the email is ready to go. Since the task is now marked "Complete", the author has no ability to re-email unless the editor resends the proofreading invitation. 

I've replicated in OJS 2.4.2 and 2.3.8.
Comment 1 Jason Nugent 2013-03-04 10:45:02 PST
fix form handling for attachments
https://github.com/pkp/ojs/commit/eb62193997d31c3eed21918520147a0638fef0d7
Comment 2 Jason Nugent 2013-03-04 10:50:02 PST
fix form handling for attachments
https://github.com/pkp/ojs/commit/317d00fc91c893554c81fb6e8622d4e7672ca0ea
Comment 3 Jason Nugent 2013-03-04 10:50:02 PST
fix form handling for attachments
https://github.com/pkp/ojs/commit/56f990ecb5e14bc2bbdbf8643b180837f1681edf
Comment 4 Jason Nugent 2013-03-04 11:05:02 PST
correctly pull 'send' parameter from request
https://github.com/pkp/ojs/commit/7ba684884acad203905bc70bab362fc24b05152d
Comment 5 Jason Nugent 2013-03-04 11:10:03 PST
correctly get parameter
https://github.com/pkp/ojs/commit/f19d1bfee6dc63f5c192555fa563939a79f24e50
Comment 6 Jason Nugent 2013-03-04 11:35:21 PST
Created attachment 3912 [details]
Patch against OJS 2.3.8
Comment 7 Jason Nugent 2013-03-04 11:35:45 PST
Created attachment 3913 [details]
Patch against OJS 2.4