Bug 8064 - Expand Masthead options to allow form field
Expand Masthead options to allow form field
Status: RESOLVED DUPLICATE of bug 8094
Product: OJS
Classification: Unclassified
Component: User Interface
3.0a
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 09:44 PST by James MacGregor
Modified: 2013-02-14 16:43 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2012-12-18 09:44:43 PST
Add a third option to the Masthead to allow a JM-editable free-text form field so that JMs could create and manage their masthead any way they see fit.
Comment 1 Alec Smecher 2012-12-18 09:47:42 PST
In OMP the masthead consists entirely of a free-form text field and I think that's a much better solution than either of our current approaches (automatic population from the Roles list, or a Manager-curated controlled listing).

The only downside to this is that it must always be manually updated, but I think that's a very minor con.
Comment 2 James MacGregor 2012-12-18 11:40:00 PST
Good to know, Alec. I think Matt may be looking at this bug as part of a custom development for Coaction (which is on the 2.3.x line), but 3.0 would be a great target for replacing the entire masthead mechanism in favour of what we have in OMP.
Comment 3 Alec Smecher 2013-02-14 16:43:42 PST
Done as part of mondo bug #8094.

*** This bug has been marked as a duplicate of bug 8094 ***