Bug 7913 - click on journal setup link on journal manager page lead to blank page
click on journal setup link on journal manager page lead to blank page
Status: RESOLVED DUPLICATE of bug 7717
Product: OJS
Classification: Unclassified
Component: Journal Management
2.3.7
PC Windows XP
: P3 critical
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 23:08 PDT by Hosein
Modified: 2012-09-18 07:44 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hosein 2012-09-14 23:08:59 PDT
Hi
after installing ojs and login and creating a journal.
i click on journal manager and click on my created journal and click on setup.
blank page appear.
i created another journal and same happen.
drop all db tables and extract ojs2.3.7 again on htdocs folder and install ojs again and just create journal and click on manager and setup and same happen

apache error log:
[Sat Sep 15 10:33:58.203125 2012] [ssl:warn] [pid 5736:tid 1884] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Sep 15 10:33:58.328125 2012] [mpm_winnt:notice] [pid 5736:tid 1884] AH00354: Child: Starting 150 worker threads.

apache access log:
127.0.0.1 - - [15/Sep/2012:10:36:34 +0430] "GET /ojs2.3.7/index.php/s2/manager/setup HTTP/1.1" 200 1186 "-" "Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1"


set debug=On
queries on page:

(mysql): SET NAMES 'utf8'   (mysql): SELECT * FROM sessions WHERE session_id = 'q9auhvtvqhmpcfb93femt9ecb5'   (mysql): SELECT * FROM users WHERE user_id = 1   (mysql): SELECT * FROM user_settings WHERE user_id = '1'   (mysql): SELECT * FROM journals WHERE path = 's2'   (mysql): SELECT * FROM site   (mysql): SELECT v.* FROM versions v LEFT JOIN plugin_settings ps ON lower(v.product_class_name) = ps.plugin_name AND ps.setting_name = 'enabled' AND ((journal_id = '1') OR v.sitewide = 1) WHERE v.current = 1 AND (ps.setting_value = '1' OR v.lazy_load <> 1)   (mysql): UPDATE sessions SET user_id = 1, ip_address = '127.0.0.1', user_agent = 'Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1', created = 1347680723, last_used = 1347689278, remember = 0, data = 'userId|s:1:\"1\";username|s:5:\"admin\";currentLocale|s:5:\"en_US\";', acting_as = 0 WHERE session_id = 'q9auhvtvqhmpcfb93femt9ecb5'
Comment 1 Hosein 2012-09-14 23:10:46 PDT
using xampp on Windows XP:
###### ApacheFriends XAMPP Version 1.8.0 ######

  + Apache 2.4.2
  + MySQL 5.5.25a (Community Server)
  + PHP 5.4.4 (VC9 X86 32bit thread safe) + PEAR 
  + phpMyAdmin 3.5.2
  + OpenSSL 1.0.1c
  + ADOdb 5.15
Comment 2 Hosein 2012-09-15 01:35:20 PDT
i checked easyphp too.
error is same
after install i forced remove line 64,65 and 66 from C:\easyphp\ojs2.3.7\lib\pkp\classes\session\Session.inc.php else this error raising:

Fatal error: Call to undefined function session_is_registered() in C:\easyphp\ojs2.3.7\lib\pkp\classes\session\Session.inc.php on line 64

that is all change on ojs code that i make.
i uncommented this 3 line of code ,but no change happen and blank page appear on 
http://127.0.0.1/ojs2.3.7/index.php/s2/manager/setup

and above error added back on
http://127.0.0.1/ojs2.3.7/index.php/s2/manager
Comment 3 Jason Nugent 2012-09-15 03:47:44 PDT
Hosein, this bug is fixed in OJS 2.4.  Please see bug #7544 for a patch that will fix this for you.

*** This bug has been marked as a duplicate of bug 7544 ***
Comment 4 Hosein 2012-09-15 19:45:59 PDT
I don't speak about session_is_registered and this lines:
		if (session_is_registered($key)) {
			session_unregister($key);	
		}
..........
I said "click on journal setup link on journal manager page lead to blank page"
and speak about what change i made on system and why i make this change for developer.
header is very simple sentence to understand what is the problem.
Comment 5 Jason Nugent 2012-09-16 05:58:54 PDT
Hosein,

You originally said:

> Fatal error: Call to undefined function session_is_registered() in
> C:\easyphp\ojs2.3.7\lib\pkp\classes\session\Session.inc.php on line 64

You are using PHP 5.4, according to this:

>  + PHP 5.4.4 (VC9 X86 32bit thread safe) + PEAR 

This function does not exist in PHP 5.4.  We have fixed this which is why I marked your bug as a duplicate.  Please apply the patch in the other bug and refrain from re-opening this bug, please.

*** This bug has been marked as a duplicate of bug 7544 ***
Comment 6 Hosein 2012-09-16 07:46:26 PDT
please don't speak about that 4 line's again.
I don't know that you never read my comment before answer or not.
I really patched  for bug 7544(please read comment 2 http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=7913#c2).
If you don't like solve this OJS bug i don't reopen this again because this is not a game or at least is not funny game.
whether there is blank page when click on journal setup link in journal manager page and this problem don't have any relation to bug 7544
Comment 7 Alec Smecher 2012-09-16 09:32:02 PDT
Hosein, it is not clear but you appear to be reporting two issues in this same bug entry. One is a duplicate, which is why the entry was flagged. (Please report one problem per bug entry to avoid this in the future.) It sounds to me like the following issue remains:

> after installing ojs and login and creating a journal.
> i click on journal manager and click on my created journal and click on setup.
> blank page appear.

Please check your PHP configuration to ensure that you know where PHP errors are being directed in the log files; it may not be the same as your Apache error log. There may be entries there that help.

There are some hints in the FAQ for blank page situations; see:
http://pkp.sfu.ca/wiki/index.php/PKP_Frequently_Asked_Questions#When_I_click_some_button_or_follow_some_link.2C_I.27m_left_with_a_blank_page._What_do_I_do.3F

Please be respectful; we're trying to help.
Comment 8 Hosein 2012-09-17 23:28:14 PDT
flow this :
you can edit your lib/pkp/includes/functions.inc.php and find the following line:

function import($class) {

Add below it:

  echo "Importing " . $class . "<br/>\n";

result: blank page display this lines:

Importing classes.core.Application
Importing lib.pkp.classes.core.PKPApplication
Importing lib.pkp.classes.core.PKPProfiler
Importing lib.pkp.classes.core.Core
Importing lib.pkp.classes.core.String
Importing lib.pkp.classes.core.Registry
Importing lib.pkp.classes.config.Config
Importing lib.pkp.classes.config.ConfigParser
Importing lib.pkp.classes.db.DAORegistry
Importing lib.pkp.classes.db.DAO
Importing lib.pkp.classes.db.DBConnection
Importing lib.pkp.classes.db.DAOResultFactory
Importing lib.pkp.classes.core.ItemIterator
Importing lib.pkp.classes.core.DataObject
Importing lib.pkp.classes.db.XMLDAO
Importing lib.pkp.classes.xml.XMLParser
Importing lib.pkp.classes.xml.XMLParserDOMHandler
Importing lib.pkp.classes.xml.XMLNode
Importing lib.pkp.classes.cache.CacheManager
Importing lib.pkp.classes.cache.FileCache
Importing lib.pkp.classes.cache.GenericCache
Importing classes.security.Validation
Importing classes.security.Role
Importing lib.pkp.classes.session.SessionManager
Importing classes.template.TemplateManager
Importing classes.search.ArticleSearch
Importing classes.search.ArticleSearchIndex
Importing lib.pkp.classes.search.SearchFileParser
Importing lib.pkp.classes.search.SearchHTMLParser
Importing lib.pkp.classes.search.SearchFileParser
Importing lib.pkp.classes.core.String
Importing lib.pkp.classes.search.SearchHelperParser
Importing lib.pkp.classes.search.SearchFileParser
Importing classes.file.PublicFileManager
Importing lib.pkp.classes.file.PKPPublicFileManager
Importing lib.pkp.classes.file.FileManager
Importing lib.pkp.classes.template.PKPTemplateManager
Importing lib.pkp.classes.plugins.PluginRegistry
Importing lib.pkp.classes.plugins.HookRegistry
Importing classes.i18n.AppLocale
Importing lib.pkp.classes.i18n.PKPLocale
Importing lib.pkp.classes.i18n.LocaleFile
Importing lib.pkp.classes.core.Dispatcher
Importing classes.core.Request
Importing lib.pkp.classes.core.PKPRequest
Importing lib.pkp.classes.core.PKPComponentRouter
Importing lib.pkp.classes.core.PKPRouter
Importing classes.core.Request
Importing classes.core.PageRouter
Importing lib.pkp.classes.core.PKPPageRouter
Importing lib.pkp.classes.core.PKPRouter
Importing lib.pkp.classes.session.SessionDAO
Importing lib.pkp.classes.session.Session
Importing classes.user.UserDAO
Importing classes.user.User
Importing lib.pkp.classes.user.PKPUser
Importing lib.pkp.classes.user.PKPUserDAO
Importing classes.journal.JournalDAO
Importing classes.journal.Journal
Importing lib.pkp.classes.site.SiteDAO
Importing lib.pkp.classes.site.Site
Importing classes.journal.JournalSettingsDAO
Importing lib.pkp.classes.site.VersionDAO
Importing lib.pkp.classes.site.Version
Importing lib.pkp.classes.plugins.GenericPlugin
Importing lib.pkp.classes.plugins.LazyLoadPlugin
Importing classes.plugins.Plugin
Importing lib.pkp.classes.plugins.PKPPlugin
Importing lib.pkp.classes.plugins.GenericPlugin
Importing lib.pkp.classes.plugins.GenericPlugin
Importing classes.plugins.PluginSettingsDAO
Importing pages.manager.SetupHandler
Comment 9 Hosein 2012-09-17 23:38:29 PDT
on cmd:
php -l ojs2.3.7/pages/manager/SetupHandler.inc.php

return:
error parsing ojs2.3.7/pages/manager/SetupHandler.inc.php line 193

when i check this line 
find:
$journal =& $router->getContext(&$request);

I remove & from line and blank page disappear.
I don't know why "&" is there.
any idea?
Comment 10 Jason Nugent 2012-09-18 06:50:11 PDT
Hi Hosein,

Yes, that line should not have the & in it.  That has actually been fixed in the newest version of OJS, version 2.4, in Alec's commit here:

https://github.com/pkp/ojs/commit/804308bb1d4bfa50808504de94b0da91b4f88f0a

So if you upgrade to OJS 2.4 (or remove that & in your own installation), the problem will be solved.

Regards,
Jason
Comment 11 Alec Smecher 2012-09-18 07:44:53 PDT

*** This bug has been marked as a duplicate of bug 7717 ***