Bug 7868 - Supplemental file form submission fails when PubId plugins have no object
Supplemental file form submission fails when PubId plugins have no object
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Submissions and Publishing
2.4.1
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 08:00 PDT by Jason Nugent
Modified: 2012-09-13 09:22 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.4 (940 bytes, patch)
2012-09-10 08:00 PDT, Jason Nugent
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Nugent 2012-09-10 08:00:04 PDT
Created attachment 3863 [details]
Patch against OJS 2.4

When the SuppFileForm is first loaded in order to create a new supplemental file, the form encounters a fatal error because there is no SuppFile available to PubIdPluginHelper.  

See:  http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=9031
Comment 1 Alec Smecher 2012-09-10 08:22:09 PDT
Regarding attachment #3863 [details] -- there's an affected case that this doesn't fix. Bozana should upload a patch shortly that includes the other area.
Comment 2 Bozana Bokan 2012-09-11 02:01:36 PDT
Jason, thanks a lot for fixing this! The fix is correct and I'll push it.
/* I've also changed the ArticleGalleyForm accordingly and will push that too. */
Comment 3 Bozana Bokan 2012-09-11 09:35:02 PDT
Supplemental file form submission fails when PubId plugins have no object
https://github.com/pkp/ojs/commit/7be07265bc1dab7451ba9e8013a5cef7cad59b2f
Comment 4 Jason Nugent 2012-09-11 15:34:01 PDT
Hi Bozana,

Not a problem at all, and thanks for the commit!  If you think that the bug is fixed, feel free to close this bug entry or mark it as a duplicate of something else.

Cheers,
Jason
Comment 5 Bozana Bokan 2012-09-13 09:19:39 PDT
Hmmm... Sorry! Somehow I am not able to close the bug -- Either because I don't know how or because I don't have the rights :-P
Comment 6 Jason Nugent 2012-09-13 09:22:26 PDT
Done :)